CVE-2022-23132
CVE-2022-23132 · Incorrect permissions of [/var/run/zabbix] forces dac_override
This page contains facts from public vulnerability sources. Check the original advisory before updating.
During Zabbix installation from RPM, DAC_OVERRIDE SELinux capability is in use to access PID files in [/var/run/zabbix] folder. In this case, Zabbix Proxy or Server processes can bypass file read, write and execute permissions check on the file system level
CVSS 3.3 · Low · EPSS 0.8% · Fix available
- Published
- Updated
Stack: system · applications
Affected products and versions
proxy, server
- Versions
- 4.0.0 - 4.0.36: Affected
- 5.0.0 – 5.0.18: Affected
- 5.4.0 – 5.4.8: Affected
- ≥ 5.0.19, < 5.0.19*: Not affected (custom)
- ≥ 5.4.9, < 5.4.9*: Not affected (custom)
No fix published
zabbix Debian:12
- Affected ranges
- ECOSYSTEM: < 1:6.0.7+dfsg-2
Update to 1:6.0.7+dfsg-2
zabbix Debian:13
- Affected ranges
- ECOSYSTEM: < 1:6.0.7+dfsg-2
Update to 1:6.0.7+dfsg-2
zabbix Debian:14
- Affected ranges
- ECOSYSTEM: < 1:6.0.7+dfsg-2
Update to 1:6.0.7+dfsg-2
zabbix Ubuntu:Pro:20.04:LTS
- Versions
- 1:4.0.4+dfsg-1build2
- 1:4.0.4+dfsg-1build3
- 1:4.0.11+dfsg-1
- 1:4.0.14+dfsg-1
- 1:4.0.15+dfsg-1
- 1:4.0.16+dfsg-1
- 1:4.0.16+dfsg-1build1
- 1:4.0.17+dfsg-1
- 1:4.0.17+dfsg-1ubuntu0.1~esm1
- 1:4.0.17+dfsg-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zabbix Ubuntu:Pro:22.04:LTS
- Versions
- 1:5.0.8+dfsg-1build1
- 1:5.0.14+dfsg-1
- 1:5.0.17+dfsg-1
- 1:5.0.17+dfsg-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://support.zabbix.com/browse/ZBX-20341
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6SZYHXINBKCY42ITFSNCYE7KCSF33VRA/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VB6W556GVXOKUYTASTDGL3AI7S3SJHX7/
- https://lists.debian.org/debian-lts-announce/2024/10/msg00000.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-23132