CVE-2022-23181
CVE-2022-23181 · Local privilege escalation with FileStore
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The fix for bug CVE-2020-9484 introduced a time of check, time of use vulnerability into Apache Tomcat 10.1.0-M1 to 10.1.0-M8, 10.0.0-M5 to 10.0.14, 9.0.35 to 9.0.56 and 8.5.55 to 8.5.73 that allowed a local attacker to perform actions with the privileges of the user that the Tomcat process is using. This issue is only exploitable when Tomcat is configured to persist sessions using the FileStore.
CVSS 7.0 · High · EPSS 0.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache tomcat
- Versions
- Apache Tomcat 10.1 10.1.0-M1 to 10.1.0-M8: Affected
- Apache Tomcat 10.0 10.0.0-M5 to 10.0.14: Affected
- Apache Tomcat 9 9.0.35 to 9.0.56: Affected
- Apache Tomcat 8 8.5.55 to 8.5.73: Affected
No fix published
tomcat9 Debian:12
- Affected ranges
- ECOSYSTEM: < 9.0.58-1
Update to 9.0.58-1
tomcat9 Debian:13
- Affected ranges
- ECOSYSTEM: < 9.0.58-1
Update to 9.0.58-1
tomcat9 Debian:14
- Affected ranges
- ECOSYSTEM: < 9.0.58-1
Update to 9.0.58-1
tomcat8 Ubuntu:Pro:16.04:LTS
- Versions
- 8.0.26-1
- 8.0.28-1
- 8.0.30-1
- 8.0.32-1
- 8.0.32-1ubuntu1
- 8.0.32-1ubuntu1.1
- 8.0.32-1ubuntu1.2
- 8.0.32-1ubuntu1.3
- 8.0.32-1ubuntu1.4
- 8.0.32-1ubuntu1.5
- 8.0.32-1ubuntu1.6
- 8.0.32-1ubuntu1.7
- 8.0.32-1ubuntu1.8
- 8.0.32-1ubuntu1.9
- 8.0.32-1ubuntu1.10
- 8.0.32-1ubuntu1.11
- 8.0.32-1ubuntu1.13
- Affected ranges
- ECOSYSTEM: < 8.0.32-1ubuntu1.13+esm1
Update to 8.0.32-1ubuntu1.13+esm1
tomcat8 Ubuntu:Pro:18.04:LTS
- Versions
- 8.5.21-1ubuntu1
- 8.5.29-1
- 8.5.30-1
- 8.5.30-1ubuntu1
- 8.5.30-1ubuntu1.2
- 8.5.30-1ubuntu1.3
- 8.5.30-1ubuntu1.4
- 8.5.39-1ubuntu1~18.04.1
- 8.5.39-1ubuntu1~18.04.2
- 8.5.39-1ubuntu1~18.04.3
- 8.5.39-1ubuntu1~18.04.3+esm1
- Affected ranges
- ECOSYSTEM: < 8.5.39-1ubuntu1~18.04.3+esm2
Update to 8.5.39-1ubuntu1~18.04.3+esm2
tomcat9 Ubuntu:Pro:18.04:LTS
- Versions
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- 9.0.16-3ubuntu0.18.04.2+esm1
- Affected ranges
- ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2+esm2
Update to 9.0.16-3ubuntu0.18.04.2+esm2
tomcat9 Ubuntu:20.04:LTS
- Versions
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- Affected ranges
- ECOSYSTEM: < 9.0.31-1ubuntu0.6
Update to 9.0.31-1ubuntu0.6
Original sources
- https://lists.apache.org/thread/l8x62p3k19yfcb208jo4zrb83k5mfwg9
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://security.netapp.com/advisory/ntap-20220217-0010/
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://lists.debian.org/debian-lts-announce/2022/10/msg00029.html
- https://www.debian.org/security/2022/dsa-5265
- https://nvd.nist.gov/vuln/detail/CVE-2022-23181