CVE-2022-23590
CVE-2022-23590 · Crash due to erroneous `StatusOr` in Tensorflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Tensorflow is an Open Source Machine Learning Framework. A `GraphDef` from a TensorFlow `SavedModel` can be maliciously altered to cause a TensorFlow process to crash due to encountering a `StatusOr` value that is an error and forcibly extracting the value from it. We have patched the issue in multiple GitHub commits and these will be included in TensorFlow 2.8.0 and TensorFlow 2.7.1, as both are affected.
CVSS 5.9 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
tensorflow
- Versions
- >= 2.7.0, < 2.8.0: Affected
No fix published
tensorflow PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.0rc0
- 2.6.0rc1
- 2.6.0rc2
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.7.0
- 2.7.0rc0
- 2.7.0rc1
- Affected ranges
- ECOSYSTEM: < 2.7.1
Update to 2.7.1
tensorflow-cpu PyPI
- Versions
- 1.15.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.7.0
- Affected ranges
- ECOSYSTEM: < 2.7.1
Update to 2.7.1
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.7.0
- 2.7.0rc0
- 2.7.0rc1
- Affected ranges
- ECOSYSTEM: < 2.7.1
Update to 2.7.1
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.7.0
- 2.7.0rc0
- 2.7.0rc1
- 2.6.4
- 2.6.5
- Affected ranges
- GIT: < 955059813cc325dc1db5e2daa6221271406d4439
- ECOSYSTEM: < 2.7.1
Update to 2.7.1
tensorflow-cpu PyPI
- Versions
- 1.15.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.7.0
- 2.7.0rc0
- 2.7.0rc1
- 2.6.4
- 2.6.5
- Affected ranges
- GIT: < 955059813cc325dc1db5e2daa6221271406d4439
- ECOSYSTEM: < 2.7.1
Update to 2.7.1
Original sources
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-pqrv-8r2f-7278
- https://github.com/tensorflow/tensorflow/commit/955059813cc325dc1db5e2daa6221271406d4439
- https://github.com/tensorflow/tensorflow/blob/274df9b02330b790aa8de1cee164b70f72b9b244/tensorflow/core/graph/graph.cc#L560-L567
- https://nvd.nist.gov/vuln/detail/CVE-2022-23590