CVE-2022-23592
CVE-2022-23592 · Out of bounds read in Tensorflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Tensorflow is an Open Source Machine Learning Framework. TensorFlow's type inference can cause a heap out of bounds read as the bounds checking is done in a `DCHECK` (which is a no-op during production). An attacker can control the `input_idx` variable such that `ix` would be larger than the number of values in `node_t.args`. The fix will be included in TensorFlow 2.8.0. This is the only affected version.
CVSS 8.1 · High · EPSS 0.9% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
tensorflow
- Versions
- = 2.8.0-rc0: Affected
No fix published
tensorflow PyPI
- Versions
- 2.8.0-rc0
- 2.8.0rc0
- 2.8.0rc1
- Affected ranges
- ECOSYSTEM: ≥ 2.8.0-rc0, < 2.8.0
Update to 2.8.0
tensorflow-cpu PyPI
- Versions
- 2.8.0-rc0
- Affected ranges
- ECOSYSTEM: ≥ 2.8.0-rc0, < 2.8.0
Update to 2.8.0
tensorflow-gpu PyPI
- Versions
- 2.8.0-rc0
- 2.8.0rc0
- 2.8.0rc1
- Affected ranges
- ECOSYSTEM: ≥ 2.8.0-rc0, < 2.8.0
Update to 2.8.0
tensorflow-cpu PyPI
- Versions
- 2.7.0
- 2.7.1
- 2.8.0rc0
- 2.8.0rc1
- 2.7.2
- 2.7.3
- 2.7.4
- Affected ranges
- GIT: < c99d98cd189839dcf51aee94e7437b54b31f8abd
- ECOSYSTEM: ≥ 2.7.0, < 2.8.0
Update to 2.8.0
tensorflow-gpu PyPI
- Versions
- 2.7.0
- 2.7.1
- 2.8.0rc0
- 2.8.0rc1
- 2.7.2
- 2.7.3
- 2.7.4
- Affected ranges
- GIT: < c99d98cd189839dcf51aee94e7437b54b31f8abd
- ECOSYSTEM: ≥ 2.7.0, < 2.8.0
Update to 2.8.0
Original sources
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vq36-27g6-p492
- https://github.com/tensorflow/tensorflow/commit/c99d98cd189839dcf51aee94e7437b54b31f8abd
- https://github.com/tensorflow/tensorflow/blob/274df9b02330b790aa8de1cee164b70f72b9b244/tensorflow/core/graph/graph.cc#L223-L229
- https://nvd.nist.gov/vuln/detail/CVE-2022-23592