CVE-2022-23614
CVE-2022-23614 · Code injection in Twig
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Twig is an open source template language for PHP. When in a sandbox mode, the `arrow` parameter of the `sort` filter must be a closure to avoid attackers being able to run arbitrary PHP functions. In affected versions this constraint was not properly enforced and could lead to code injection of arbitrary PHP code. Patched versions now disallow calling non Closure in the `sort` filter as is the case for some other filters. Users are advised to upgrade.
CVSS 8.8 · High · EPSS 8.2% · Fix available
- Published
- Updated
Affected products and versions
twig
- Versions
- >= 3.0.0, < 3.3.8: Affected
- >= 2.0.0, < 2.14.11: Affected
No fix published
php-twig Debian:12
- Affected ranges
- ECOSYSTEM: < 3.3.8-1
Update to 3.3.8-1
php-twig Debian:13
- Affected ranges
- ECOSYSTEM: < 3.3.8-1
Update to 3.3.8-1
php-twig Debian:14
- Affected ranges
- ECOSYSTEM: < 3.3.8-1
Update to 3.3.8-1
twig/twig Packagist
- Versions
- v2.0.0
- v2.1.0
- v2.10.0
- v2.11.0
- v2.11.1
- v2.11.2
- v2.11.3
- v2.12.0
- v2.12.1
- v2.12.2
- v2.12.3
- v2.12.4
- v2.12.5
- v2.13.0
- v2.13.1
- v2.14.0
- v2.14.1
- v2.14.10
- v2.14.2
- v2.14.3
- v2.14.4
- v2.14.5
- v2.14.6
- v2.14.7
- v2.14.8
- v2.14.9
- v2.2.0
- v2.3.0
- v2.3.1
- v2.3.2
- v2.4.0
- v2.4.1
- v2.4.2
- v2.4.3
- v2.4.4
- v2.4.5
- v2.4.6
- v2.4.7
- v2.4.8
- v2.5.0
- v2.6.0
- v2.6.1
- v2.6.2
- v2.7.0
- v2.7.1
- v2.7.2
- v2.7.3
- v2.7.4
- v2.8.0
- v2.8.1
- v2.9.0
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0, < 2.14.11
Update to 2.14.11
twig/twig Packagist
- Versions
- v3.0.0
- v3.0.1
- v3.0.2
- v3.0.3
- v3.0.4
- v3.0.5
- v3.1.0
- v3.1.1
- v3.2.1
- v3.3.0
- v3.3.1
- v3.3.2
- v3.3.3
- v3.3.4
- v3.3.5
- v3.3.6
- v3.3.7
- Affected ranges
- ECOSYSTEM: ≥ 3.0.0, < 3.3.8
Update to 3.3.8
php-twig Ubuntu:Pro:20.04:LTS
- Versions
- 2.11.3-2
- 2.12.1-1
- 2.12.2-1
- 2.12.3-1
- 2.12.5-1
- Affected ranges
- ECOSYSTEM: < 2.12.5-1ubuntu0.1~esm1
Update to 2.12.5-1ubuntu0.1~esm1
Original sources
- https://github.com/twigphp/Twig/security/advisories/GHSA-5mv2-rx3q-4w2v
- https://github.com/twigphp/Twig/commit/22b9dc3c03ee66d7e21d9ed2ca76052b134cb9e9
- https://github.com/twigphp/Twig/commit/2eb33080558611201b55079d07ac88f207b466d5
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OTN4273U4RHVIXED64T7DSMJ3VYTPRE7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PECHIY2XLWUH2WLCNPDGNFMPHPRPCEDZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/I2PVV5DUTRUECTIHMTWRI5Z7DVNYQ2YO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SIGZCFSYLPP7UVJ4E4NLHSOQSKYNXSAD/
- https://www.debian.org/security/2022/dsa-5107
- https://nvd.nist.gov/vuln/detail/CVE-2022-23614