p PatchFirst

CVE-2022-23646

CVE-2022-23646 · Improper CSP in Image Optimization API for Next.js

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Next.js is a React framework. Starting with version 10.0.0 and prior to version 12.1.0, Next.js is vulnerable to User Interface (UI) Misrepresentation of Critical Information. In order to be affected, the `next.config.js` file must have an `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default, the instance is not affected. Version 12.1.0 contains a patch for this issue. As a workaround, change `next.config.js` to use a different `loader configuration` other than the default.

CVSS 5.9 · Medium · EPSS 1.8% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next.js

    Versions
    • >= 10.0.0, < 12.1.0: Affected

    No fix published

  • next npm

    Affected ranges
    • SEMVER: ≥ 10.0.0, < 12.1.0

    Update to 12.1.0

Original sources

Check your server →