CVE-2022-24066
CVE-2022-24066 · Command Injection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The package simple-git before 3.5.0 are vulnerable to Command Injection due to an incomplete fix of [CVE-2022-24433](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-2421199) which only patches against the git fetch attack vector. A similar use of the --upload-pack feature of git is also supported for git clone, which the prior fix didn't cover.
CVSS 8.1 · High · EPSS 3.9% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
simple-git
- Versions
- ≥ unspecified, < 3.5.0: Affected (custom)
Update to 3.5.0
simple-git npm
- Affected ranges
- SEMVER: < 3.5.0
Update to 3.5.0