CVE-2022-24086
CVE-2022-24086 · Adobe Commerce checkout improper input validation leads to remote code execution
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability during the checkout process. Exploitation of this issue does not require user interaction and could result in arbitrary code execution.
CVSS 9.8 · Critical · EPSS 99.2% · In KEV · Public exploit · Fix available
- Published
- Updated
Stack: php
Affected products and versions
magento commerce
- Versions
- ≥ unspecified, ≤ 2.4.3-p1: Affected (custom)
- ≥ unspecified, ≤ 2.3.7-p2: Affected (custom)
- ≥ unspecified, ≤ None: Affected (custom)
No fix published
magento/community-edition Packagist
- Versions
- 2.3.3-p1
- 2.3.4
- 2.3.4-p2
- 2.3.5
- 2.3.5-p1
- 2.3.5-p2
- 2.3.6
- 2.3.6-p1
- 2.3.7
- 2.3.7-p1
- 2.3.7-p2
- Affected ranges
- ECOSYSTEM: ≥ 2.3.3-p1, < 2.3.7-p3
Update to 2.3.7-p3
magento/community-edition Packagist
- Versions
- 2.4.0
- 2.4.0-p1
- 2.4.1
- 2.4.1-p1
- 2.4.2
- 2.4.2-p1
- 2.4.2-p2
- 2.4.3
- 2.4.3-p1
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.3-p2
Update to 2.4.3-p2