p PatchFirst

CVE-2022-24303

CVE-2022-24303

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Pillow before 9.0.1 allows attackers to delete files because spaces in temporary pathnames are mishandled.

CVSS 9.1 · Critical · EPSS 2.7% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pillow Debian:12

    Affected ranges
    • ECOSYSTEM: < 9.0.1-1

    Update to 9.0.1-1

  • pillow Debian:13

    Affected ranges
    • ECOSYSTEM: < 9.0.1-1

    Update to 9.0.1-1

  • pillow Debian:14

    Affected ranges
    • ECOSYSTEM: < 9.0.1-1

    Update to 9.0.1-1

  • pillow PyPI

    Versions
    • 1.0
    • 1.1
    • 1.2
    • 1.3
    • 1.4
    • 1.5
    • 1.6
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.7.4
    • 1.7.5
    • 1.7.6
    • 1.7.7
    • 1.7.8
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.4.0
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.6.0
    • 2.6.1
    • 2.6.2
    • 2.7.0
    • 2.8.0
    • 2.8.1
    • 2.8.2
    • 2.9.0
    • 3.0.0
    • 3.1.0
    • 3.1.0.rc1
    • 3.1.0rc1
    • 3.1.1
    • 3.1.2
    • 3.2.0
    • 3.3.0
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.4.0
    • 3.4.1
    • 3.4.2
    • 4.0.0
    • 4.1.0
    • 4.1.1
    • 4.2.0
    • 4.2.1
    • 4.3.0
    • 5.0.0
    • 5.1.0
    • 5.2.0
    • 5.3.0
    • 5.4.0
    • 5.4.0.dev0
    • 5.4.1
    • 6.0.0
    • 6.1.0
    • 6.2.0
    • 6.2.1
    • 6.2.2
    • 7.0.0
    • 7.1.0
    • 7.1.1
    • 7.1.2
    • 7.2.0
    • 8.0.0
    • 8.0.1
    • 8.1.0
    • 8.1.1
    • 8.1.2
    • 8.2.0
    • 8.3.0
    • 8.3.1
    • 8.3.2
    • 8.4.0
    • 9.0.0
    Affected ranges
    • ECOSYSTEM: < 9.0.1

    Update to 9.0.1

  • pillow Ubuntu:20.04:LTS

    Versions
    • 6.1.0-1
    • 6.1.0-1build1
    • 6.2.1-2
    • 7.0.0-4
    • 7.0.0-4build1
    • 7.0.0-4ubuntu0.1
    • 7.0.0-4ubuntu0.2
    • 7.0.0-4ubuntu0.3
    • 7.0.0-4ubuntu0.4
    • 7.0.0-4ubuntu0.5
    • 7.0.0-4ubuntu0.6
    Affected ranges
    • ECOSYSTEM: < 7.0.0-4ubuntu0.7

    Update to 7.0.0-4ubuntu0.7

  • pillow-python2 Ubuntu:Pro:20.04:LTS

    Versions
    • 6.2.1-3~build1
    • 6.2.1-3
    Affected ranges
    • ECOSYSTEM: < 6.2.1-3ubuntu0.1~esm1

    Update to 6.2.1-3ubuntu0.1~esm1

Original sources

Check your server →