p PatchFirst

CVE-2022-24375

CVE-2022-24375 · Denial of Service (DoS)

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) when bypassing the limitations for excessive memory consumption by sending multiple CloseSession requests with the deleteSubscription parameter equal to False.

CVSS 7.5 · High · EPSS 1.7% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • node-opcua

    Versions
    • ≥ unspecified, < 2.74.0: Affected (custom)

    Update to 2.74.0

  • node-opcua npm

    Affected ranges
    • SEMVER: < 2.74.0

    Update to 2.74.0

Original sources

Check your server →