CVE-2022-24433
CVE-2022-24433 · Command Injection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The package simple-git before 3.3.0 are vulnerable to Command Injection via argument injection. When calling the .fetch(remote, branch, handlerFn) function, both the remote and branch parameters are passed to the git fetch subcommand. By injecting some git options it was possible to get arbitrary command execution.
CVSS 8.1 · High · EPSS 3.7% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
simple-git
- Versions
- ≥ unspecified, < 3.3.0: Affected (custom)
Update to 3.3.0
simple-git npm
- Affected ranges
- SEMVER: < 3.3.0
Update to 3.3.0