CVE-2022-24754
CVE-2022-24754 · Buffer overflow in pjsip
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PJSIP is a free and open source multimedia communication library written in C language. In versions prior to and including 2.12 PJSIP there is a stack-buffer overflow vulnerability which only impacts PJSIP users who accept hashed digest credentials (credentials with data_type `PJSIP_CRED_DATA_DIGEST`). This issue has been patched in the master branch of the PJSIP repository and will be included with the next release. Users unable to upgrade need to check that the hashed digest data length must be equal to `PJSIP_MD5STRLEN` before passing to PJSIP.
CVSS 8.5 · High · EPSS 2.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
pjproject
- Versions
- <= 2.12: Affected
No fix published
ring Debian:12
- Affected ranges
- ECOSYSTEM: < 20230206.0~ds1-1
Update to 20230206.0~ds1-1
pjproject Ubuntu:Pro:16.04:LTS
- Versions
- 2.1.0.0.ast20130823-1
- 2.1.0.0.ast20130823-1+deb8u1build0.16.04.1
- 2.1.0.0.ast20130823-1+deb8u1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pjproject Ubuntu:Pro:18.04:LTS
- Versions
- 2.6~dfsg-2
- 2.7~dfsg-1
- 2.7.1~dfsg-1
- 2.7.1~dfsg-1build1
- 2.7.2~dfsg-1
- 2.7.2~dfsg-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ring Ubuntu:Pro:18.04:LTS
- Versions
- 20170803.2.5fcfe3f~dfsg1-1
- 20171024.1.eadbdeb~ds1-1
- 20171129.2.cf5bbff~ds1-1
- 20171129.2.cf5bbff~ds1-2
- 20180119.1.9e06f94~ds1-1
- 20180119.1.9e06f94~ds1-3
- 20180222.1.7bffde2~ds2-2
- 20180228.1.503da2b~ds1-1
- 20180228.1.503da2b~ds1-1build1
- Affected ranges
- ECOSYSTEM: < 20180228.1.503da2b~ds1-1ubuntu0.1~esm1
Update to 20180228.1.503da2b~ds1-1ubuntu0.1~esm1
ring Ubuntu:20.04:LTS
- Versions
- 20190215.1.f152c98~ds1-1
- 20190215.1.f152c98~ds1-1build1
- 20190215.1.f152c98~ds1-1build2
- Affected ranges
- ECOSYSTEM: < 20190215.1.f152c98~ds1-1+deb10u2build0.20.04.1
Update to 20190215.1.f152c98~ds1-1+deb10u2build0.20.04.1
Original sources
- https://github.com/pjsip/pjproject/security/advisories/GHSA-73f7-48m9-w662
- https://github.com/pjsip/pjproject/commit/d27f79da11df7bc8bb56c2f291d71e54df8d2c47
- https://lists.debian.org/debian-lts-announce/2022/03/msg00035.html
- https://security.gentoo.org/glsa/202210-37
- https://lists.debian.org/debian-lts-announce/2023/08/msg00038.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00030.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-24754