p PatchFirst

CVE-2022-24778

CVE-2022-24778 · Incorrect Authorization in imgcrypt

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The imgcrypt library provides API exensions for containerd to support encrypted container images and implements the ctd-decoder command line tool for use by containerd to decrypt encrypted container images. The imgcrypt function `CheckAuthorization` is supposed to check whether the current used is authorized to access an encrypted image and prevent the user from running an image that another user previously decrypted on the same system. In versions prior to 1.1.4, a failure occurs when an image with a ManifestList is used and the architecture of the local host is not the first one in the ManifestList. Only the first architecture in the list was tested, which may not have its layers available locally since it could not be run on the host architecture. Therefore, the verdict on unavailable layers was that the image could be run anticipating that image run failure would occur later due to the layers not being available. However, this verdict to allow the image to run enabled other architectures in the ManifestList to run an image without providing keys if that image had previously been decrypted. A patch has been applied to imgcrypt 1.1.4. Workarounds may include usage of different namespaces for each remote user.

CVSS 7.5 · High · EPSS 2.7% · Fix available

Published
Updated

Stack: system · containers

Affected products and versions

  • imgcrypt

    Versions
    • < 1.1.4: Affected

    No fix published

  • containerd Ubuntu:Pro:16.04:LTS

    Versions
    • 0.2.1-0ubuntu4~16.04
    • 0.2.3-0ubuntu1~16.04
    • 0.2.5-0ubuntu1~16.04.1
    • 1.2.6-0ubuntu1~16.04.2
    • 1.2.6-0ubuntu1~16.04.3
    • 1.2.6-0ubuntu1~16.04.4
    • 1.2.6-0ubuntu1~16.04.5
    • 1.2.6-0ubuntu1~16.04.6
    • 1.2.6-0ubuntu1~16.04.6+esm1
    • 1.2.6-0ubuntu1~16.04.6+esm2
    • 1.2.6-0ubuntu1~16.04.6+esm4
    • 1.2.6-0ubuntu1~16.04.6+esm5
    • 1.2.6-0ubuntu1~16.04.6+esm6
    • 1.2.6-0ubuntu1~16.04.6+esm7
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • containerd Ubuntu:18.04:LTS

    Versions
    • 0.2.5-0ubuntu2
    • 1.2.6-0ubuntu1~18.04.1
    • 1.2.6-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.1
    • 1.3.3-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.3
    • 1.3.3-0ubuntu1~18.04.4
    • 1.4.4-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.1
    • 1.5.2-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.3
    • 1.5.5-0ubuntu3~18.04.1
    • 1.5.5-0ubuntu3~18.04.2
    • 1.5.9-0ubuntu1~18.04.1
    Affected ranges
    • ECOSYSTEM: < 1.5.9-0ubuntu1~18.04.2

    Update to 1.5.9-0ubuntu1~18.04.2

  • containerd Ubuntu:20.04:LTS

    Versions
    • 1.2.10-0ubuntu1
    • 1.3.2-0ubuntu1
    • 1.3.3-0ubuntu1
    • 1.3.3-0ubuntu2
    • 1.3.3-0ubuntu2.1
    • 1.3.3-0ubuntu2.2
    • 1.3.3-0ubuntu2.3
    • 1.4.4-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.1
    • 1.5.2-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.3
    • 1.5.5-0ubuntu3~20.04.1
    • 1.5.5-0ubuntu3~20.04.2
    • 1.5.9-0ubuntu1~20.04.1
    • 1.5.9-0ubuntu1~20.04.4
    • 1.5.9-0ubuntu1~20.04.5
    Affected ranges
    • ECOSYSTEM: < 1.5.9-0ubuntu1~20.04.6

    Update to 1.5.9-0ubuntu1~20.04.6

  • containerd Ubuntu:22.04:LTS

    Versions
    • 1.5.5-0ubuntu3
    • 1.5.9-0ubuntu1
    • 1.5.9-0ubuntu2
    • 1.5.9-0ubuntu3
    Affected ranges
    • ECOSYSTEM: < 1.5.9-0ubuntu3.1

    Update to 1.5.9-0ubuntu3.1

Original sources

Check your server →