CVE-2022-24823
CVE-2022-24823 · Local Information Disclosure Vulnerability in io.netty:netty-codec-http
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Netty is an open-source, asynchronous event-driven network application framework. The package `io.netty:netty-codec-http` prior to version 4.1.77.Final contains an insufficient fix for CVE-2021-21290. When Netty's multipart decoders are used local information disclosure can occur via the local system temporary directory if temporary storing uploads on the disk is enabled. This only impacts applications running on Java version 6 and lower. Additionally, this vulnerability impacts code running on Unix-like systems, and very old versions of Mac OSX and Windows as they all share the system temporary directory between all users. Version 4.1.77.Final contains a patch for this vulnerability. As a workaround, specify one's own `java.io.tmpdir` when starting the JVM or use DefaultHttpDataFactory.setBaseDir(...) to set the directory to something that is only readable by the current user.
CVSS 5.5 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
netty
- Versions
- <= 4.1.76.Final: Affected
No fix published
netty Debian:12
- Versions
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-15
- 1:4.1.48-16
- 1:4.1.48-7
- 1:4.1.48-7+deb12u1
- 1:4.1.48-7+deb12u2
- 1:4.1.48-8
- 1:4.1.48-9
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
netty Debian:13
- Versions
- 1:4.1.48-10
- 1:4.1.48-10+deb13u1
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-15
- 1:4.1.48-16
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
netty Debian:14
- Versions
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-15
- 1:4.1.48-16
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
netty Ubuntu:Pro:14.04:LTS
- Versions
- 1:3.2.6.Final-2
- 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
- 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
netty Ubuntu:Pro:16.04:LTS
- Versions
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- 1:4.0.34-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm2
Update to 1:4.0.34-1ubuntu0.1~esm2
netty Ubuntu:Pro:18.04:LTS
- Versions
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- 1:4.1.7-4ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm3
Update to 1:4.1.7-4ubuntu0.1+esm3
netty Ubuntu:Pro:20.04:LTS
- Versions
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- 1:4.1.45-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm2
Update to 1:4.1.45-1ubuntu0.1~esm2
netty Ubuntu:Pro:22.04:LTS
- Versions
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.1~esm1
Update to 1:4.1.48-4+deb11u2ubuntu0.1~esm1
netty Ubuntu:Pro:24.04:LTS
- Versions
- 1:4.1.48-7
- 1:4.1.48-8
- 1:4.1.48-9
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-9ubuntu0.1~esm1
Update to 1:4.1.48-9ubuntu0.1~esm1
netty Ubuntu:25.10
- Versions
- 1:4.1.48-10
- 1:4.1.48-10ubuntu0.25.10.1
- 1:4.1.48-10ubuntu0.25.10.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
netty Ubuntu:26.10
- Versions
- 1:4.1.48-16
- 1:4.1.48-16ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
netty Ubuntu:Pro:26.04:LTS
- Versions
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-16
- 1:4.1.48-16ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/netty/netty/security/advisories/GHSA-269q-hmxg-m83q
- https://github.com/netty/netty/security/advisories/GHSA-5mcr-gq6c-3hq2
- https://github.com/netty/netty/commit/185f8b2756a36aaa4f973f1a2a025e7d981823f1
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://security.netapp.com/advisory/ntap-20220616-0004/
- https://nvd.nist.gov/vuln/detail/CVE-2022-24823