CVE-2022-24963
CVE-2022-24963 · Apache Portable Runtime (APR): out-of-bound writes in the apr_encode family of functions
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Integer Overflow or Wraparound vulnerability in apr_encode functions of Apache Portable Runtime (APR) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime (APR) version 1.7.0.
CVSS 9.8 · Critical · EPSS 1.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache portable runtime (apr)
- Versions
- 1.7.0: Affected
No fix published
apr Debian:12
- Affected ranges
- ECOSYSTEM: < 1.7.2-1
Update to 1.7.2-1
apr Debian:13
- Affected ranges
- ECOSYSTEM: < 1.7.2-1
Update to 1.7.2-1
apr Debian:14
- Affected ranges
- ECOSYSTEM: < 1.7.2-1
Update to 1.7.2-1
apr Ubuntu:22.04:LTS
- Versions
- 1.7.0-6ubuntu1
- 1.7.0-8
- 1.7.0-8build1
- Affected ranges
- ECOSYSTEM: < 1.7.0-8ubuntu0.22.04.1
Update to 1.7.0-8ubuntu0.22.04.1