p PatchFirst

CVE-2022-2509

CVE-2022-2509

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability found in gnutls. This security flaw happens because of a double free error occurs during verification of pkcs7 signatures in gnutls_pkcs7_verify function.

CVSS 7.5 · High · EPSS 2.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gnutls

    Versions
    • gnutls 3.7.7(Fixed): Affected

    No fix published

  • gnutls28 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.7.7-1

    Update to 3.7.7-1

  • gnutls28 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.7.7-1

    Update to 3.7.7-1

  • gnutls28 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.7.7-1

    Update to 3.7.7-1

  • gnutls28 Ubuntu:18.04:LTS

    Versions
    • 3.5.8-6ubuntu3
    • 3.5.17-1ubuntu1
    • 3.5.17-1ubuntu3
    • 3.5.18-1ubuntu1
    • 3.5.18-1ubuntu1.1
    • 3.5.18-1ubuntu1.2
    • 3.5.18-1ubuntu1.3
    • 3.5.18-1ubuntu1.4
    • 3.5.18-1ubuntu1.5
    Affected ranges
    • ECOSYSTEM: < 3.5.18-1ubuntu1.6

    Update to 3.5.18-1ubuntu1.6

  • gnutls28 Ubuntu:20.04:LTS

    Versions
    • 3.6.9-5ubuntu1
    • 3.6.9-5ubuntu2
    • 3.6.10-5
    • 3.6.11.1-2
    • 3.6.11.1-2ubuntu2
    • 3.6.13-2ubuntu1
    • 3.6.13-2ubuntu1.1
    • 3.6.13-2ubuntu1.2
    • 3.6.13-2ubuntu1.3
    • 3.6.13-2ubuntu1.6
    Affected ranges
    • ECOSYSTEM: < 3.6.13-2ubuntu1.7

    Update to 3.6.13-2ubuntu1.7

  • gnutls28 Ubuntu:22.04:LTS

    Versions
    • 3.7.1-5ubuntu1
    • 3.7.2-2ubuntu1
    • 3.7.2-4ubuntu1
    • 3.7.2-5ubuntu1
    • 3.7.3-4ubuntu1
    Affected ranges
    • ECOSYSTEM: < 3.7.3-4ubuntu1.1

    Update to 3.7.3-4ubuntu1.1

Original sources

Check your server →