CVE-2022-25231
CVE-2022-25231 · Denial of Service (DoS)
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) by sending a specifically crafted OPC UA message with a special OPC UA NodeID, when the requested memory allocation exceeds the v8’s memory limit.
CVSS 7.5 · High · EPSS 1.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
node-opcua
- Versions
- ≥ unspecified, < 2.74.0: Affected (custom)
Update to 2.74.0
node-opcua npm
- Affected ranges
- SEMVER: < 2.74.0
Update to 2.74.0