p PatchFirst

CVE-2022-25274

CVE-2022-25274

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Drupal 9.3 implemented a generic entity access API for entity revisions. However, this API was not completely integrated with existing permissions, resulting in some possible access bypass for users who have access to use revisions of content generally, but who do not have access to individual items of node and media content. This vulnerability only affects sites using Drupal's revision system.

CVSS 5.4 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • core

    Versions
    • ≥ 9.3, < 9.3.12: Affected (custom)

    Update to 9.3.12

  • drupal/core Packagist

    Versions
    • 9.3.0
    • 9.3.1
    • 9.3.10
    • 9.3.11
    • 9.3.2
    • 9.3.3
    • 9.3.4
    • 9.3.5
    • 9.3.6
    • 9.3.7
    • 9.3.8
    • 9.3.9
    Affected ranges
    • ECOSYSTEM: ≥ 9.3.0, < 9.3.12

    Update to 9.3.12

  • drupal/core Packagist

    Versions
    • 9.3.0
    • 9.3.1
    • 9.3.10
    • 9.3.11
    • 9.3.2
    • 9.3.3
    • 9.3.4
    • 9.3.5
    • 9.3.6
    • 9.3.7
    • 9.3.8
    • 9.3.9
    Affected ranges
    • ECOSYSTEM: ≥ 9.3.0, < 9.3.12

    Update to 9.3.12

  • drupal7 Ubuntu:Pro:14.04:LTS

    Versions
    • 7.23-1
    • 7.24-1
    • 7.24-2
    • 7.26-1
    • 7.26-1ubuntu0.1
    • 7.26-1ubuntu0.1+esm1
    • 7.26-1ubuntu0.1+esm2
    • 7.26-1ubuntu0.1+esm3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • drupal7 Ubuntu:Pro:16.04:LTS

    Versions
    • 7.38-1
    • 7.41-1
    • 7.44-1ubuntu1~16.04.0
    • 7.44-1ubuntu1~16.04.0+esm1
    • 7.44-1ubuntu1~16.04.0+esm2
    • 7.44-1ubuntu1~16.04.0+esm3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →