p PatchFirst

CVE-2022-25303

CVE-2022-25303 · Cross-site Scripting (XSS)

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The package whoogle-search before 0.7.2 are vulnerable to Cross-site Scripting (XSS) via the query string parameter q. In the case where it does not contain the http string, it is used to build the error_message that is then rendered in the error.html template, using the [flask.render_template](https://flask.palletsprojects.com/en/2.1.x/api/flask.render_template) function. However, the error_message is rendered using the [| safe filter](https://jinja.palletsprojects.com/en/3.1.x/templates/working-with-automatic-escaping), meaning the user input is not escaped.

CVSS 5.4 · Medium · EPSS 1.0% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • whoogle-search

    Versions
    • ≥ unspecified, < 0.7.2: Affected (custom)

    Update to 0.7.2

  • whoogle-search PyPI

    Versions
    • 0.1.0
    • 0.1.3
    • 0.1.4
    • 0.2.0
    • 0.2.1
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.4.0
    • 0.4.1
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.6.0
    • 0.7.0
    • 0.7.1
    Affected ranges
    • ECOSYSTEM: < 0.7.2

    Update to 0.7.2

  • whoogle-search PyPI

    Versions
    • 0.1.0
    • 0.1.3
    • 0.1.4
    • 0.2.0
    • 0.2.1
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.4.0
    • 0.4.1
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.6.0
    • 0.7.0
    • 0.7.1
    Affected ranges
    • GIT: < abc30d7da3b5c67be7ce84d4699f327442d44606
    • ECOSYSTEM: < 0.7.2

    Update to 0.7.2

Original sources

Check your server →