CVE-2022-25640
CVE-2022-25640
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.
CVSS 7.5 · High · EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wolfssl Debian:12
- Affected ranges
- ECOSYSTEM: < 5.2.0-1
Update to 5.2.0-1
wolfssl Debian:13
- Affected ranges
- ECOSYSTEM: < 5.2.0-1
Update to 5.2.0-1
wolfssl Ubuntu:16.04:LTS
- Versions
- 3.4.8+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:18.04:LTS
- Versions
- 3.10.2+dfsg-2
- 3.12.0+dfsg-1
- 3.12.2+dfsg-1
- 3.13.0+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:20.04:LTS
- Versions
- 4.1.0+dfsg-2
- 4.2.0+dfsg-1
- 4.2.0+dfsg-2
- 4.2.0+dfsg-3
- 4.3.0+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:22.04:LTS
- Versions
- 4.6.0-3
- 5.0.0-1
- 5.1.1-1
- 5.2.0-1
- 5.2.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published