p PatchFirst

CVE-2022-25763

CVE-2022-25763 · Improper input validation on HTTP/2 headers

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper Input Validation vulnerability in HTTP/2 request validation of Apache Traffic Server allows an attacker to create smuggle or cache poison attacks. This issue affects Apache Traffic Server 8.0.0 to 9.1.2.

CVSS 6.8 · Medium · EPSS 2.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache traffic server

    Versions
    • 8.0.0 to 9.1.2: Affected

    No fix published

  • trafficserver Debian:12

    Affected ranges
    • ECOSYSTEM: < 9.1.3+ds-1

    Update to 9.1.3+ds-1

  • trafficserver Ubuntu:16.04:LTS

    Versions
    • 5.3.0-2ubuntu1
    • 5.3.0-2ubuntu2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • trafficserver Ubuntu:18.04:LTS

    Versions
    • 7.0.0-5
    • 7.1.2+ds-2
    • 7.1.2+ds-2build1
    • 7.1.2+ds-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • trafficserver Ubuntu:Pro:20.04:LTS

    Versions
    • 8.0.5+ds-1
    • 8.0.5+ds-2
    • 8.0.5+ds-2build1
    • 8.0.5+ds-2ubuntu1
    • 8.0.5+ds-3
    • 8.0.5+ds-3ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • trafficserver Ubuntu:Pro:22.04:LTS

    Versions
    • 8.1.1+ds-1.1
    • 9.1.1+ds-2build1
    • 9.1.1+ds-2ubuntu0.1~esm1
    • 9.1.1+ds-2ubuntu0.1
    • 9.1.1+ds-2ubuntu0.1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →