CVE-2022-25770
CVE-2022-25770 · Insufficient authentication in upgrade flow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Mautic allows you to update the application via an upgrade script. The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation. This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable.
CVSS 7.8 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
mautic
- Versions
- ≥ >= 1.0.0-beta3, < < 4.4.13: Affected (semver)
- ≥ >= 5.0.0, < < 5.1.1.: Affected (semver)
No fix published
mautic/core Packagist
- Versions
- 1.0.0
- 1.0.0-beta3
- 1.0.0-beta4
- 1.0.0-rc1
- 1.0.0-rc2
- 1.0.0-rc3
- 1.0.0-rc4
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.2.0
- 1.2.0-beta1
- 1.2.1
- 1.2.2
- 1.2.3
- 1.2.4
- 1.3.0
- 1.3.1
- 1.4.0
- 1.4.1
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.10.0
- 2.10.0-beta
- 2.10.1
- 2.11.0
- 2.11.0-beta
- 2.12.0
- 2.12.0-beta
- 2.12.1
- 2.12.1-beta
- 2.12.2
- 2.12.2-beta
- 2.13.0
- 2.13.0-beta
- 2.13.1
- 2.14.0
- 2.14.0-beta
- 2.14.1
- 2.14.1-beta
- 2.14.2
- 2.14.2-beta
- 2.15.0
- 2.15.0-beta
- 2.15.1
- 2.15.1-beta
- 2.15.2
- 2.15.2-beta
- 2.15.3
- 2.15.3-beta
- 2.16.0
- 2.16.0-beta
- 2.16.1
- 2.16.1-beta
- 2.16.2
- 2.16.2-beta
- 2.16.3
- 2.16.3-beta
- 2.16.4
- 2.16.5
- 2.2.0
- 2.2.1
- 2.3.0
- 2.4.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.6.1
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.8.2
- 2.9.0
- 2.9.0-beta
- 2.9.1
- 2.9.2
- 3.0.0
- 3.0.0-alpha
- 3.0.0-beta
- 3.0.0-beta2
- 3.0.1
- 3.0.2
- 3.0.2-rc
- 3.1.0
- 3.1.0-rc
- 3.1.1
- 3.1.1-rc
- 3.1.2
- 3.1.2-rc
- 3.2.0
- 3.2.0-rc
- 3.2.1
- 3.2.2
- 3.2.2-rc
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.5-rc
- 3.3.0
- 3.3.0-rc
- 3.3.1
- 3.3.2
- 3.3.2-rc
- 3.3.3
- 3.3.3-rc
- 3.3.4
- 3.3.5
- 4.0.0
- 4.0.0-alpha1
- 4.0.0-beta
- 4.0.0-rc
- 4.0.1
- 4.0.2
- 4.1.0
- 4.1.1
- 4.1.2
- 4.2.0
- 4.2.0-rc
- 4.2.0-rc1
- 4.2.1
- 4.2.2
- 4.3.0
- 4.3.0-beta
- 4.3.0-rc
- 4.3.1
- 4.4.0
- 4.4.0-beta
- 4.4.1
- 4.4.10
- 4.4.11
- 4.4.12
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.7
- 4.4.8
- 4.4.9
- Affected ranges
- ECOSYSTEM: ≥ 1.0.0-beta3, < 4.4.13
Update to 4.4.13
mautic/core Packagist
- Versions
- 5.0.0
- 5.0.0-alpha
- 5.0.0-alpha1
- 5.0.0-beta1
- 5.0.0-beta2
- 5.0.0-rc1
- 5.0.0-rc2
- 5.0.1
- 5.0.2
- 5.0.3
- 5.0.4
- 5.1.0
- Affected ranges
- ECOSYSTEM: ≥ 5.0.0-alpha, < 5.1.1
Update to 5.1.1
mautic/core-lib Packagist
- Versions
- 4.0.0
- 4.0.0-alpha1
- 4.0.0-beta
- 4.0.0-rc
- 4.0.1
- 4.0.2
- 4.1.0
- 4.1.1
- 4.1.2
- 4.2.0
- 4.2.0-rc
- 4.2.0-rc1
- 4.2.1
- 4.2.2
- 4.3.0
- 4.3.0-beta
- 4.3.0-rc
- 4.3.1
- 4.4.0
- 4.4.1
- 4.4.1-alpha
- 4.4.10
- 4.4.11
- 4.4.12
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.7
- 4.4.8
- 4.4.9
- Affected ranges
- ECOSYSTEM: ≥ 1.0.0-beta3, < 4.4.13
Update to 4.4.13
mautic/core-lib Packagist
- Versions
- 5.0.0
- 5.0.0-alpha
- 5.0.0-alpha1
- 5.0.0-beta1
- 5.0.0-beta2
- 5.0.0-rc1
- 5.0.0-rc2
- 5.0.1
- 5.0.2
- 5.0.3
- 5.0.4
- 5.1.0
- Affected ranges
- ECOSYSTEM: ≥ 5.0.0-alpha, < 5.1.1
Update to 5.1.1