p PatchFirst

CVE-2022-25875

CVE-2022-25875 · Cross-site Scripting (XSS)

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The package svelte before 3.49.0 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization and to improper escape of attributes when using objects during SSR (Server-Side Rendering). Exploiting this vulnerability is possible via objects with a custom toString() function.

CVSS 5.4 · Medium · EPSS 1.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • svelte

    Versions
    • ≥ unspecified, < 3.49.0: Affected (custom)

    Update to 3.49.0

  • svelte npm

    Affected ranges
    • SEMVER: < 3.49.0

    Update to 3.49.0

Original sources

Check your server →