CVE-2022-25887
CVE-2022-25887 · Regular Expression Denial of Service (ReDoS)
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The package sanitize-html before 2.7.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure global regular expression replacement logic of HTML comment removal.
CVSS 5.3 · Medium · EPSS 1.6% · Fix available
- Published
- Updated
Affected products and versions
sanitize-html
- Versions
- ≥ unspecified, < 2.7.1: Affected (custom)
Update to 2.7.1
node-sanitize-html Debian:12
- Affected ranges
- ECOSYSTEM: < 2.7.1+~2.6.2-1
Update to 2.7.1+~2.6.2-1
node-sanitize-html Debian:13
- Affected ranges
- ECOSYSTEM: < 2.7.1+~2.6.2-1
Update to 2.7.1+~2.6.2-1
node-sanitize-html Debian:14
- Affected ranges
- ECOSYSTEM: < 2.7.1+~2.6.2-1
Update to 2.7.1+~2.6.2-1
sanitize-html npm
- Affected ranges
- SEMVER: < 2.7.1
Update to 2.7.1
node-sanitize-html Ubuntu:22.04:LTS
- Versions
- 2.6.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jupyter-notebook Ubuntu:Pro:22.04:LTS
- Versions
- 6.2.0-1
- 6.4.5-2
- 6.4.5-3
- 6.4.5-4
- 6.4.8-1
- 6.4.8-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 6.4.8-1ubuntu0.1+esm1
Update to 6.4.8-1ubuntu0.1+esm1
node-sanitize-html Ubuntu:24.04:LTS
- Versions
- 2.8.0+~2.6.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jupyter-notebook Ubuntu:Pro:24.04:LTS
- Versions
- 6.4.12-2.2
- 6.4.12-2.2ubuntu1
- Affected ranges
- ECOSYSTEM: < 6.4.12-2.2ubuntu1+esm1
Update to 6.4.12-2.2ubuntu1+esm1
jupyter-notebook Ubuntu:25.10
- Versions
- 6.4.13-5
- 6.4.13-5ubuntu0.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-sanitize-html Ubuntu:25.10
- Versions
- 2.14.0+~2.13.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jupyter-notebook Ubuntu:26.10
- Versions
- 6.4.13-5ubuntu0.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-sanitize-html Ubuntu:26.10
- Versions
- 2.14.0+~2.13.0-1
- 2.17.0+~2.16.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jupyter-notebook Ubuntu:26.04:LTS
- Versions
- 6.4.13-5ubuntu0.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-sanitize-html Ubuntu:26.04:LTS
- Versions
- 2.14.0+~2.13.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://security.snyk.io/vuln/SNYK-JS-SANITIZEHTML-2957526
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3008102
- https://github.com/apostrophecms/sanitize-html/pull/557
- https://github.com/apostrophecms/sanitize-html/commit/b4682c12fd30e12e82fa2d9b766de91d7d2cd23c
- https://nvd.nist.gov/vuln/detail/CVE-2022-25887