p PatchFirst

CVE-2022-25892

CVE-2022-25892 · Denial of Service (DoS)

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed.

CVSS 7.5 · High · EPSS 1.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • muhammara

    Versions
    • ≥ unspecified, < 2.6.1: Affected (custom)
    • ≥ 3.1.0, < unspecified: Affected (custom)
    • ≥ unspecified, < 3.1.1: Affected (custom)

    Update to 2.6.1; Update to 3.1.1

  • hummus

    Versions
    • ≥ 0, < unspecified: Affected (custom)

    No fix published

  • muhammara npm

    Affected ranges
    • SEMVER: < 2.6.1

    Update to 2.6.1

  • muhammara npm

    Affected ranges
    • SEMVER: ≥ 3.0.0, < 3.1.1

    Update to 3.1.1

  • hummus npm

    Affected ranges
    • SEMVER: < 1.0.111

    Update to 1.0.111

Original sources

Check your server →