CVE-2022-25927
CVE-2022-25927
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of the package ua-parser-js from 0.7.30 and before 0.7.33, from 0.8.1 and before 1.0.33 are vulnerable to Regular Expression Denial of Service (ReDoS) via the trim() function.
CVSS 5.3 · Medium · EPSS 1.7% · Fix available
- Published
- Updated
Affected products and versions
ua-parser-js
- Versions
- ≥ 0.7.30, < 0.7.33: Affected (semver)
- ≥ 0.8.1, < 1.0.33: Affected (semver)
Update to 0.7.33; Update to 1.0.33
node-ua-parser-js Debian:12
- Affected ranges
- ECOSYSTEM: < 0.8.1+ds+~0.7.36-3
Update to 0.8.1+ds+~0.7.36-3
node-ua-parser-js Debian:13
- Affected ranges
- ECOSYSTEM: < 0.8.1+ds+~0.7.36-3
Update to 0.8.1+ds+~0.7.36-3
node-ua-parser-js Debian:14
- Affected ranges
- ECOSYSTEM: < 0.8.1+ds+~0.7.36-3
Update to 0.8.1+ds+~0.7.36-3
ua-parser-js npm
- Affected ranges
- SEMVER: ≥ 0.7.30, < 0.7.33
Update to 0.7.33
ua-parser-js npm
- Affected ranges
- SEMVER: ≥ 0.8.0, < 1.0.33
Update to 1.0.33
node-ua-parser-js Ubuntu:18.04:LTS
- Versions
- 0.7.14-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-ua-parser-js Ubuntu:20.04:LTS
- Versions
- 0.7.14-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-ua-parser-js Ubuntu:22.04:LTS
- Versions
- 0.7.24+ds-1
- 0.7.24+ds-2
- 0.7.31+ds+~0.7.36-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-ua-parser-js Ubuntu:24.04:LTS
- Versions
- 0.8.1+ds+~0.7.36-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-ua-parser-js Ubuntu:25.10
- Versions
- 0.8.1+ds+~0.7.36-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-ua-parser-js Ubuntu:26.10
- Versions
- 0.8.1+ds+~0.7.36-3
- 2.0.10+ds+~cs0.3.5-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-ua-parser-js Ubuntu:26.04:LTS
- Versions
- 0.8.1+ds+~0.7.36-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published