CVE-2022-26354
CVE-2022-26354
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in the vhost-vsock device of QEMU. In case of error, an invalid element was not detached from the virtqueue before freeing its memory, leading to memory leakage and other unexpected results. Affected QEMU versions <= 6.2.0.
CVSS 3.2 · Low · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
qemu-kvm
- Versions
- Affected QEMU versions <= 6.2.0: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 1:7.0+dfsg-1
Update to 1:7.0+dfsg-1
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 1:7.0+dfsg-1
Update to 1:7.0+dfsg-1
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 1:7.0+dfsg-1
Update to 1:7.0+dfsg-1
qemu Ubuntu:18.04:LTS
- Versions
- 1:2.10+dfsg-0ubuntu3
- 1:2.10+dfsg-0ubuntu4
- 1:2.10+dfsg-0ubuntu5
- 1:2.11+dfsg-1ubuntu1
- 1:2.11+dfsg-1ubuntu2
- 1:2.11+dfsg-1ubuntu4
- 1:2.11+dfsg-1ubuntu5
- 1:2.11+dfsg-1ubuntu6
- 1:2.11+dfsg-1ubuntu7
- 1:2.11+dfsg-1ubuntu7.1
- 1:2.11+dfsg-1ubuntu7.2
- 1:2.11+dfsg-1ubuntu7.3
- 1:2.11+dfsg-1ubuntu7.4
- 1:2.11+dfsg-1ubuntu7.5
- 1:2.11+dfsg-1ubuntu7.6
- 1:2.11+dfsg-1ubuntu7.7
- 1:2.11+dfsg-1ubuntu7.8
- 1:2.11+dfsg-1ubuntu7.9
- 1:2.11+dfsg-1ubuntu7.10
- 1:2.11+dfsg-1ubuntu7.12
- 1:2.11+dfsg-1ubuntu7.13
- 1:2.11+dfsg-1ubuntu7.14
- 1:2.11+dfsg-1ubuntu7.15
- 1:2.11+dfsg-1ubuntu7.17
- 1:2.11+dfsg-1ubuntu7.18
- 1:2.11+dfsg-1ubuntu7.19
- 1:2.11+dfsg-1ubuntu7.20
- 1:2.11+dfsg-1ubuntu7.21
- 1:2.11+dfsg-1ubuntu7.22
- 1:2.11+dfsg-1ubuntu7.23
- 1:2.11+dfsg-1ubuntu7.25
- 1:2.11+dfsg-1ubuntu7.26
- 1:2.11+dfsg-1ubuntu7.27
- 1:2.11+dfsg-1ubuntu7.28
- 1:2.11+dfsg-1ubuntu7.29
- 1:2.11+dfsg-1ubuntu7.31
- 1:2.11+dfsg-1ubuntu7.32
- 1:2.11+dfsg-1ubuntu7.33
- 1:2.11+dfsg-1ubuntu7.34
- 1:2.11+dfsg-1ubuntu7.35
- 1:2.11+dfsg-1ubuntu7.36
- 1:2.11+dfsg-1ubuntu7.37
- 1:2.11+dfsg-1ubuntu7.38
- 1:2.11+dfsg-1ubuntu7.39
- Affected ranges
- ECOSYSTEM: < 1:2.11+dfsg-1ubuntu7.40
Update to 1:2.11+dfsg-1ubuntu7.40
qemu Ubuntu:20.04:LTS
- Versions
- 1:4.0+dfsg-0ubuntu9
- 1:4.0+dfsg-0ubuntu10
- 1:4.2-1ubuntu1
- 1:4.2-1ubuntu2
- 1:4.2-3ubuntu1
- 1:4.2-3ubuntu2
- 1:4.2-3ubuntu3
- 1:4.2-3ubuntu4
- 1:4.2-3ubuntu5
- 1:4.2-3ubuntu6
- 1:4.2-3ubuntu6.1
- 1:4.2-3ubuntu6.2
- 1:4.2-3ubuntu6.3
- 1:4.2-3ubuntu6.4
- 1:4.2-3ubuntu6.5
- 1:4.2-3ubuntu6.6
- 1:4.2-3ubuntu6.7
- 1:4.2-3ubuntu6.8
- 1:4.2-3ubuntu6.9
- 1:4.2-3ubuntu6.10
- 1:4.2-3ubuntu6.11
- 1:4.2-3ubuntu6.12
- 1:4.2-3ubuntu6.14
- 1:4.2-3ubuntu6.15
- 1:4.2-3ubuntu6.16
- 1:4.2-3ubuntu6.17
- 1:4.2-3ubuntu6.18
- 1:4.2-3ubuntu6.19
- 1:4.2-3ubuntu6.21
- Affected ranges
- ECOSYSTEM: < 1:4.2-3ubuntu6.23
Update to 1:4.2-3ubuntu6.23
qemu Ubuntu:22.04:LTS
- Versions
- 1:6.0+dfsg-2expubuntu1
- 1:6.0+dfsg-2expubuntu2
- 1:6.0+dfsg-2expubuntu4
- 1:6.2+dfsg-2ubuntu5
- 1:6.2+dfsg-2ubuntu6
- 1:6.2+dfsg-2ubuntu6.1
- Affected ranges
- ECOSYSTEM: < 1:6.2+dfsg-2ubuntu6.2
Update to 1:6.2+dfsg-2ubuntu6.2
Original sources
- https://gitlab.com/qemu-project/qemu/-/commit/8d1b247f3748ac4078524130c6d7ae42b6140aaf
- https://lists.debian.org/debian-lts-announce/2022/04/msg00002.html
- https://security.netapp.com/advisory/ntap-20220425-0003/
- https://www.debian.org/security/2022/dsa-5133
- https://security.gentoo.org/glsa/202208-27
- https://lists.debian.org/debian-lts-announce/2022/09/msg00008.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-26354