CVE-2022-26360
CVE-2022-26360
This page contains facts from public vulnerability sources. Check the original advisory before updating.
IOMMU: RMRR (VT-d) and unity map (AMD-Vi) handling issues T[his CNA information record relates to multiple CVEs; the text explains which aspects/vulnerabilities correspond to which CVE.] Certain PCI devices in a system might be assigned Reserved Memory Regions (specified via Reserved Memory Region Reporting, "RMRR") for Intel VT-d or Unity Mapping ranges for AMD-Vi. These are typically used for platform tasks such as legacy USB emulation. Since the precise purpose of these regions is unknown, once a device associated with such a region is active, the mappings of these regions need to remain continuouly accessible by the device. This requirement has been violated. Subsequent DMA or interrupts from the device may have unpredictable behaviour, ranging from IOMMU faults to memory corruption.
CVSS 7.8 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
xen
- Versions
- consult Xen advisory XSA-400: Unknown
No fix published
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.16.1-1
Update to 4.16.1-1
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.16.1-1
Update to 4.16.1-1
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.16.1-1
Update to 4.16.1-1
xen Ubuntu:16.04:LTS
- Versions
- 4.5.1-0ubuntu1
- 4.5.1-0ubuntu2
- 4.6.0-1ubuntu1
- 4.6.0-1ubuntu2
- 4.6.0-1ubuntu4
- 4.6.0-1ubuntu4.1
- 4.6.0-1ubuntu4.2
- 4.6.0-1ubuntu4.3
- 4.6.5-0ubuntu1
- 4.6.5-0ubuntu1.1
- 4.6.5-0ubuntu1.2
- 4.6.5-0ubuntu1.4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:18.04:LTS
- Versions
- 4.9.0-0ubuntu3
- 4.9.0-0ubuntu4
- 4.9.2-0ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:20.04:LTS
- Versions
- 4.9.2-0ubuntu2
- 4.9.2-0ubuntu6
- 4.9.2-0ubuntu7
- 4.11.3+24-g14b62ab3e5-1ubuntu1
- 4.11.3+24-g14b62ab3e5-1ubuntu2
- 4.11.3+24-g14b62ab3e5-1ubuntu2.2
- 4.11.3+24-g14b62ab3e5-1ubuntu2.3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:22.04:LTS
- Versions
- 4.11.4+24-gddaaccbbab-1ubuntu2
- 4.16.0-1~ubuntu2
- 4.16.0-1~ubuntu2.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:24.04:LTS
- Versions
- 4.17.2-1
- 4.17.2+55-g0b56bed864-1
- 4.17.2+76-ge1f9cb16e2-1
- 4.17.2+76-ge1f9cb16e2-1ubuntu1
- 4.17.3+10-g091466ba55-1
- 4.17.3+10-g091466ba55-1.1ubuntu2
- 4.17.3+10-g091466ba55-1.1ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:25.10
- Versions
- 4.20.0-1ubuntu1
- 4.20.0+68-g35cb38b222-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:26.10
- Versions
- 4.20.2+7-g1badcf5035-2build2
- 4.20.2+37-g61ff35323e-1ubuntu1
- 4.20.3+127-gc42374a105-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:26.04:LTS
- Versions
- 4.20.0+68-g35cb38b222-1
- 4.20.2+7-g1badcf5035-2
- 4.20.2+7-g1badcf5035-2build2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://xenbits.xenproject.org/xsa/advisory-400.txt
- http://xenbits.xen.org/xsa/advisory-400.html
- http://www.openwall.com/lists/oss-security/2022/04/05/3
- https://www.debian.org/security/2022/dsa-5117
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UHFSRVLM2JUCPDC2KGB7ETPQYJLCGBLD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6ETPM2OVZZ6KOS2L7QO7SIW6XWT5OW3F/
- https://security.gentoo.org/glsa/202402-07
- https://nvd.nist.gov/vuln/detail/CVE-2022-26360