p PatchFirst

CVE-2022-27451

CVE-2022-27451

This page contains facts from public vulnerability sources. Check the original advisory before updating.

MariaDB Server v10.9 and below was discovered to contain a segmentation fault via the component sql/field_conv.cc.

CVSS 7.5 · High · EPSS 1.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mariadb-10.5 Debian:11

    Versions
    • 1:10.5.11-1
    • 1:10.5.12-0+deb11u1
    • 1:10.5.12-1
    • 1:10.5.13-0+deb11u1
    • 1:10.5.15-0+deb11u1
    Affected ranges
    • ECOSYSTEM: < 1:10.5.18-0+deb11u1

    Update to 1:10.5.18-0+deb11u1

  • mariadb-10.1 Ubuntu:18.04:LTS

    Versions
    • 10.1.25-1
    • 1:10.1.29-6
    • 1:10.1.34-0ubuntu0.18.04.1
    • 1:10.1.38-0ubuntu0.18.04.1
    • 1:10.1.38-0ubuntu0.18.04.2
    • 1:10.1.40-0ubuntu0.18.04.1
    • 1:10.1.41-0ubuntu0.18.04.1
    • 1:10.1.43-0ubuntu0.18.04.1
    • 1:10.1.44-0ubuntu0.18.04.1
    • 1:10.1.47-0ubuntu0.18.04.1
    • 1:10.1.48-0ubuntu0.18.04.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mariadb-10.3 Ubuntu:20.04:LTS

    Versions
    • 1:10.3.17-1
    • 1:10.3.18-1
    • 1:10.3.19-1
    • 1:10.3.21-2
    • 1:10.3.22-1
    • 1:10.3.22-1ubuntu1
    • 1:10.3.25-0ubuntu0.20.04.1
    • 1:10.3.29-0ubuntu0.20.04.1
    • 1:10.3.30-0ubuntu0.20.04.1
    • 1:10.3.31-0ubuntu0.20.04.1
    • 1:10.3.32-0ubuntu0.20.04.1
    • 1:10.3.34-0ubuntu0.20.04.1
    Affected ranges
    • ECOSYSTEM: < 1:10.3.37-0ubuntu0.20.04.1

    Update to 1:10.3.37-0ubuntu0.20.04.1

  • mariadb-10.6 Ubuntu:22.04:LTS

    Versions
    • 1:10.6.7-2ubuntu1
    • 1:10.6.7-2ubuntu1.1
    Affected ranges
    • ECOSYSTEM: < 1:10.6.11-0ubuntu0.22.04.1

    Update to 1:10.6.11-0ubuntu0.22.04.1

Original sources

Check your server →