CVE-2022-2868
CVE-2022-2868
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libtiff's tiffcrop utility has a improper input validation flaw that can lead to out of bounds read and ultimately cause a crash if an attacker is able to supply a crafted file to tiffcrop.
CVSS 5.5 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libtiff
- Versions
- libtiff 4.4.0rc1: Affected
No fix published
tiff Debian:12
- Affected ranges
- ECOSYSTEM: < 4.4.0~rc1-1
Update to 4.4.0~rc1-1
tiff Debian:13
- Affected ranges
- ECOSYSTEM: < 4.4.0~rc1-1
Update to 4.4.0~rc1-1
tiff Debian:14
- Affected ranges
- ECOSYSTEM: < 4.4.0~rc1-1
Update to 4.4.0~rc1-1
tiff Ubuntu:Pro:14.04:LTS
- Versions
- 4.0.2-4ubuntu3
- 4.0.3-5ubuntu1
- 4.0.3-6
- 4.0.3-6ubuntu1
- 4.0.3-7
- 4.0.3-7ubuntu0.1
- 4.0.3-7ubuntu0.2
- 4.0.3-7ubuntu0.3
- 4.0.3-7ubuntu0.4
- 4.0.3-7ubuntu0.6
- 4.0.3-7ubuntu0.7
- 4.0.3-7ubuntu0.8
- 4.0.3-7ubuntu0.9
- 4.0.3-7ubuntu0.10
- 4.0.3-7ubuntu0.11
- 4.0.3-7ubuntu0.11+esm1
- 4.0.3-7ubuntu0.11+esm2
- Affected ranges
- ECOSYSTEM: < 4.0.3-7ubuntu0.11+esm3
Update to 4.0.3-7ubuntu0.11+esm3
tiff Ubuntu:Pro:16.04:LTS
- Versions
- 4.0.3-12.3ubuntu2
- 4.0.5-1
- 4.0.6-1
- 4.0.6-1ubuntu0.1
- 4.0.6-1ubuntu0.2
- 4.0.6-1ubuntu0.3
- 4.0.6-1ubuntu0.4
- 4.0.6-1ubuntu0.5
- 4.0.6-1ubuntu0.6
- 4.0.6-1ubuntu0.7
- 4.0.6-1ubuntu0.8
- 4.0.6-1ubuntu0.8+esm1
- 4.0.6-1ubuntu0.8+esm2
- Affected ranges
- ECOSYSTEM: < 4.0.6-1ubuntu0.8+esm3
Update to 4.0.6-1ubuntu0.8+esm3
tiff Ubuntu:18.04:LTS
- Versions
- 4.0.8-5
- 4.0.8-6
- 4.0.9-1
- 4.0.9-2
- 4.0.9-3
- 4.0.9-4
- 4.0.9-4ubuntu1
- 4.0.9-5
- 4.0.9-5ubuntu0.1
- 4.0.9-5ubuntu0.2
- 4.0.9-5ubuntu0.3
- 4.0.9-5ubuntu0.4
- 4.0.9-5ubuntu0.5
- 4.0.9-5ubuntu0.6
- 4.0.9-5ubuntu0.7
- Affected ranges
- ECOSYSTEM: < 4.0.9-5ubuntu0.8
Update to 4.0.9-5ubuntu0.8
tiff Ubuntu:20.04:LTS
- Versions
- 4.0.10+git191003-1
- 4.1.0+git191117-1
- 4.1.0+git191117-2
- 4.1.0+git191117-2build1
- 4.1.0+git191117-2ubuntu0.20.04.1
- 4.1.0+git191117-2ubuntu0.20.04.2
- 4.1.0+git191117-2ubuntu0.20.04.3
- 4.1.0+git191117-2ubuntu0.20.04.4
- 4.1.0+git191117-2ubuntu0.20.04.5
- Affected ranges
- ECOSYSTEM: < 4.1.0+git191117-2ubuntu0.20.04.6
Update to 4.1.0+git191117-2ubuntu0.20.04.6
tiff Ubuntu:22.04:LTS
- Versions
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.0-3build1
- 4.3.0-4
- 4.3.0-5
- 4.3.0-6
- 4.3.0-6ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 4.3.0-6ubuntu0.2
Update to 4.3.0-6ubuntu0.2