CVE-2022-28959
CVE-2022-28959
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
CVSS 6.1 · Medium · EPSS 1.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
spip Debian:13
- Affected ranges
- ECOSYSTEM: < 3.2.8-1
Update to 3.2.8-1
spip Debian:14
- Affected ranges
- ECOSYSTEM: < 3.2.8-1
Update to 3.2.8-1
spip Ubuntu:Pro:16.04:LTS
- Versions
- 3.0.20-1
- 3.0.21-1
- 3.0.21-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 3.0.21-1ubuntu1+esm1
Update to 3.0.21-1ubuntu1+esm1
spip Ubuntu:Pro:18.04:LTS
- Versions
- 3.1.4-3
- 3.1.4-4~deb9u3build0.18.04.1
- 3.1.4-4~deb9u5build0.18.04.1
- Affected ranges
- ECOSYSTEM: < 3.1.4-4~deb9u5ubuntu0.1~esm2
Update to 3.1.4-4~deb9u5ubuntu0.1~esm2
Original sources
- https://thinkloveshare.com/en/hacking/rce_on_spip_and_root_me/
- https://blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-SPIP-3-2-8-et-SPIP-3-1-13.html
- https://www.root-me.org/fr/Informations/Faiblesses-decouvertes/
- https://github.com/spip/SPIP/commit/0394b44774555ae8331b6e65e35065dfa0bb41e4
- https://github.com/spip/SPIP/commit/6c1650713fc948318852ace759aab8f1a84791cf
- https://nvd.nist.gov/vuln/detail/CVE-2022-28959