CVE-2022-29203
CVE-2022-29203 · Integer overflow in `SpaceToBatchND` in TensorFlow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.SpaceToBatchND` (in all backends such as XLA and handwritten kernels) is vulnerable to an integer overflow: The result of this integer overflow is used to allocate the output tensor, hence we get a denial of service via a `CHECK`-failure (assertion failure), as in TFSA-2021-198. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.
CVSS 5.5 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
tensorflow
- Versions
- < 2.6.4: Affected
- >= 2.7.0rc0, < 2.7.2: Affected
- >= 2.8.0rc0, < 2.8.1: Affected
- >= 2.9.0rc0, < 2.9.0: Affected
No fix published
tensorflow PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.0rc0
- 2.6.0rc1
- 2.6.0rc2
- 2.6.1
- 2.6.2
- 2.6.3
- Affected ranges
- ECOSYSTEM: < 2.6.4
Update to 2.6.4
tensorflow PyPI
- Versions
- 2.7.0
- 2.7.1
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.2
Update to 2.7.2
tensorflow PyPI
- Versions
- 2.8.0
- Affected ranges
- ECOSYSTEM: ≥ 2.8.0, < 2.8.1
Update to 2.8.1
tensorflow-cpu PyPI
- Versions
- 1.15.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- Affected ranges
- ECOSYSTEM: < 2.6.4
Update to 2.6.4
tensorflow-cpu PyPI
- Versions
- 2.7.0
- 2.7.1
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.2
Update to 2.7.2
tensorflow-cpu PyPI
- Versions
- 2.8.0
- Affected ranges
- ECOSYSTEM: ≥ 2.8.0, < 2.8.1
Update to 2.8.1
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- Affected ranges
- ECOSYSTEM: < 2.6.4
Update to 2.6.4
tensorflow-gpu PyPI
- Versions
- 2.7.0
- 2.7.1
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.2
Update to 2.7.2
tensorflow-gpu PyPI
- Versions
- 2.8.0
- Affected ranges
- ECOSYSTEM: ≥ 2.8.0, < 2.8.1
Update to 2.8.1
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.7.0
- 2.7.1
- 2.8.0
- Affected ranges
- ECOSYSTEM: < 2.6.4 ∪ ≥ 2.7.0, < 2.7.2 ∪ ≥ 2.8.0, < 2.8.1
Update to 2.6.4; Update to 2.7.2; Update to 2.8.1
tensorflow PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.0rc0
- 2.6.0rc1
- 2.6.0rc2
- 2.6.1
- 2.6.2
- 2.6.3
- 2.7.0
- 2.7.1
- 2.8.0
- Affected ranges
- ECOSYSTEM: < 2.6.4 ∪ ≥ 2.7.0, < 2.7.2 ∪ ≥ 2.8.0, < 2.8.1
Update to 2.6.4; Update to 2.7.2; Update to 2.8.1
tensorflow-cpu PyPI
- Versions
- 1.15.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.7.0
- 2.7.1
- 2.8.0
- Affected ranges
- ECOSYSTEM: < 2.6.4 ∪ ≥ 2.7.0, < 2.7.2 ∪ ≥ 2.8.0, < 2.8.1
Update to 2.6.4; Update to 2.7.2; Update to 2.8.1
Original sources
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2021-198.md
- https://github.com/tensorflow/tensorflow/releases/tag/v2.6.4
- https://github.com/tensorflow/tensorflow/releases/tag/v2.7.2
- https://github.com/tensorflow/tensorflow/releases/tag/v2.8.1
- https://github.com/tensorflow/tensorflow/releases/tag/v2.9.0
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-jjm6-4vf7-cjh4
- https://github.com/tensorflow/tensorflow/commit/acd56b8bcb72b163c834ae4f18469047b001fadf
- https://nvd.nist.gov/vuln/detail/CVE-2022-29203