CVE-2022-29257
CVE-2022-29257 · Electron's AutoUpdater module fails to validate certain nested components of the bundle
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Electron is a framework for writing cross-platform desktop applications using JavaScript (JS), HTML, and CSS. A vulnerability in versions prior to 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 allows attackers who have control over a given apps update server / update storage to serve maliciously crafted update packages that pass the code signing validation check but contain malicious code in some components. This kind of attack would require significant privileges in a potential victim's own auto updating infrastructure and the ease of that attack entirely depends on the potential victim's infrastructure security. Electron versions 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 contain a fix for this issue. There are no known workarounds.
CVSS 6.6 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
electron
- Versions
- < 15.5.5: Affected
- >= 16.0.0-beta.1, < 16.2.6: Affected
- >= 17.0.0-beta.1, < 17.2.0: Affected
- >= 18.0.0-beta.1, <= 18.0.0-beta.5: Affected
No fix published
electron npm
- Affected ranges
- SEMVER: < 15.5.0
Update to 15.5.0
electron npm
- Affected ranges
- SEMVER: ≥ 16.0.0, < 16.2.0
Update to 16.2.0
electron npm
- Affected ranges
- SEMVER: ≥ 17.0.0, < 17.2.0
Update to 17.2.0
electron npm
- Affected ranges
- SEMVER: ≥ 18.0.0-beta.1, < 18.0.0-beta.6
Update to 18.0.0-beta.6