p PatchFirst

CVE-2022-2986

CVE-2022-2986

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Enabling and disabling installed H5P libraries did not include the necessary token to prevent a CSRF risk.

CVSS 8.8 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • moodle

    Versions
    • moodle 4.0.3 and moodle 3.11.9: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • v3.11.0
    • v3.11.0-beta
    • v3.11.0-rc1
    • v3.11.0-rc2
    • v3.11.1
    • v3.11.2
    • v3.11.3
    • v3.11.4
    • v3.11.5
    • v3.11.6
    • v3.11.7
    • v3.11.8
    Affected ranges
    • ECOSYSTEM: ≥ 3.11, < 3.11.9

    Update to 3.11.9

  • moodle/moodle Packagist

    Versions
    • v4.0.0
    • v4.0.0-beta
    • v4.0.0-rc1
    • v4.0.0-rc2
    • v4.0.0-rc3
    • v4.0.0-rc4
    • v4.0.1
    • v4.0.2
    Affected ranges
    • ECOSYSTEM: ≥ 4.0, < 4.0.3

    Update to 4.0.3

  • moodle Ubuntu:Pro:16.04:LTS

    Versions
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • moodle Ubuntu:Pro:18.04:LTS

    Versions
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →