CVE-2022-30067
CVE-2022-30067
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GIMP 2.10.30 and 2.99.10 are vulnerable to Buffer Overflow. Through a crafted XCF file, the program will allocate for a huge amount of memory, resulting in insufficient memory or program crash.
CVSS 5.5 · Medium · EPSS 0.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
gimp Debian:12
- Affected ranges
- ECOSYSTEM: < 2.10.32-1
Update to 2.10.32-1
gimp Debian:13
- Affected ranges
- ECOSYSTEM: < 2.10.32-1
Update to 2.10.32-1
gimp Debian:14
- Affected ranges
- ECOSYSTEM: < 2.10.32-1
Update to 2.10.32-1
gimp Ubuntu:Pro:16.04:LTS
- Versions
- 2.8.14-1ubuntu2
- 2.8.14-1.2ubuntu1
- 2.8.16-1ubuntu1
- 2.8.16-1ubuntu1.1
- 2.8.16-1ubuntu1.1+esm1
- 2.8.16-1ubuntu1.1+esm2
- 2.8.16-1ubuntu1.1+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gimp Ubuntu:Pro:18.04:LTS
- Versions
- 2.8.20-1
- 2.8.20-1.1
- 2.8.20-2
- 2.8.22-1
- 2.8.22-1ubuntu0.1~esm1
- 2.8.22-1ubuntu0.1~esm2
- 2.8.22-1ubuntu0.1~esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gimp Ubuntu:20.04:LTS
- Versions
- 2.10.8-2
- 2.10.14-2
- 2.10.14-2build1
- 2.10.14-2ubuntu1
- 2.10.14-3
- 2.10.18-1
- Affected ranges
- ECOSYSTEM: < 2.10.18-1ubuntu0.1
Update to 2.10.18-1ubuntu0.1
gimp Ubuntu:22.04:LTS
- Versions
- 2.10.24-2
- 2.10.28-1
- 2.10.30-1
- 2.10.30-1build1
- Affected ranges
- ECOSYSTEM: < 2.10.30-1ubuntu0.1
Update to 2.10.30-1ubuntu0.1