CVE-2022-30429
CVE-2022-30429
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple cross-site scripting (XSS) vulnerabilities in Neos CMS allow attackers with the editor role or higher to inject arbitrary script or HTML code using the editor function, the deletion of assets, or a workspace title. The vulnerabilities were found in versions 3.3.29 and 8.0.1 and could also be present in all intermediate versions.
CVSS 5.4 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
neos/neos Packagist
- Versions
- 3.3.0
- 3.3.1
- 3.3.10
- 3.3.11
- 3.3.12
- 3.3.13
- 3.3.14
- 3.3.15
- 3.3.16
- 3.3.17
- 3.3.18
- 3.3.19
- 3.3.2
- 3.3.20
- 3.3.21
- 3.3.22
- 3.3.23
- 3.3.24
- 3.3.25
- 3.3.26
- 3.3.27
- 3.3.28
- 3.3.29
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- 3.3.9
- 4.0.0
- 4.0.1
- 4.0.10
- 4.0.11
- 4.0.12
- 4.0.13
- 4.0.14
- 4.0.15
- 4.0.16
- 4.0.17
- 4.0.18
- 4.0.19
- 4.0.2
- 4.0.20
- 4.0.21
- 4.0.22
- 4.0.23
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.0.8
- 4.0.9
- 4.1.0
- 4.1.1
- 4.1.10
- 4.1.11
- 4.1.12
- 4.1.13
- 4.1.14
- 4.1.15
- 4.1.16
- 4.1.17
- 4.1.18
- 4.1.19
- 4.1.2
- 4.1.20
- 4.1.21
- 4.1.22
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 4.1.7
- 4.1.8
- 4.1.9
- 4.2.0
- 4.2.1
- 4.2.10
- 4.2.11
- 4.2.12
- 4.2.13
- 4.2.14
- 4.2.15
- 4.2.16
- 4.2.17
- 4.2.18
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.2.9
- 4.3.0
- 4.3.1
- 4.3.10
- 4.3.11
- 4.3.12
- 4.3.13
- 4.3.14
- 4.3.15
- 4.3.16
- 4.3.17
- 4.3.18
- 4.3.19
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.3.6
- 4.3.7
- 4.3.8
- 4.3.9
- Affected ranges
- ECOSYSTEM: ≥ 3.3.0, < 4.4.0
Update to 4.4.0
neos/neos Packagist
- Versions
- 5.3.0
- 5.3.1
- 5.3.2
- 5.3.3
- 5.3.4
- 5.3.5
- 5.3.6
- 5.3.7
- 5.3.8
- 5.3.9
- Affected ranges
- ECOSYSTEM: ≥ 5.3.0, < 5.3.10
Update to 5.3.10
neos/neos Packagist
- Versions
- 7.0.0
- 7.0.1
- 7.0.2
- 7.0.3
- 7.0.4
- 7.0.5
- 7.0.6
- 7.0.7
- 7.0.8
- Affected ranges
- ECOSYSTEM: ≥ 7.0.0, < 7.0.9
Update to 7.0.9
neos/neos Packagist
- Versions
- 7.1.0
- 7.1.1
- 7.1.2
- 7.1.3
- 7.1.4
- 7.1.5
- 7.1.6
- Affected ranges
- ECOSYSTEM: ≥ 7.1.0, < 7.1.7
Update to 7.1.7
neos/neos Packagist
- Versions
- 7.2.0
- 7.2.1
- 7.2.2
- 7.2.3
- 7.2.4
- 7.2.5
- Affected ranges
- ECOSYSTEM: ≥ 7.2.0, < 7.2.6
Update to 7.2.6
neos/neos Packagist
- Versions
- 7.3.0
- 7.3.1
- 7.3.2
- 7.3.3
- Affected ranges
- ECOSYSTEM: ≥ 7.3.0, < 7.3.4
Update to 7.3.4
neos/neos Packagist
- Versions
- 8.0.0
- 8.0.1
- Affected ranges
- ECOSYSTEM: ≥ 8.0.0, < 8.0.2
Update to 8.0.2