p PatchFirst

CVE-2022-31127

CVE-2022-31127 · Improper handling of email input in next-auth

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NextAuth.js is a complete open source authentication solution for Next.js applications. An attacker can pass a compromised input to the e-mail [signin endpoint](https://next-auth.js.org/getting-started/rest-api#post-apiauthsigninprovider) that contains some malicious HTML, tricking the e-mail server to send it to the user, so they can perform a phishing attack. Eg.: `[email protected], <a href="http://attacker.com">Before signing in, claim your money!</a>`. This was previously sent to `[email protected]`, and the content of the email containing a link to the attacker's site was rendered in the HTML. This has been remedied in the following releases, by simply not rendering that e-mail in the HTML, since it should be obvious to the receiver what e-mail they used: next-auth v3 users before version 3.29.8 are impacted. (We recommend upgrading to v4, as v3 is considered unmaintained. next-auth v4 users before version 4.9.0 are impacted. If for some reason you cannot upgrade, the workaround requires you to sanitize the `email` parameter that is passed to `sendVerificationRequest` and rendered in the HTML. If you haven't created a custom `sendVerificationRequest`, you only need to upgrade. Otherwise, make sure to either exclude `email` from the HTML body or efficiently sanitize it.

CVSS 7.1 · High · EPSS 1.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next-auth

    Versions
    • < 3.29.8: Affected
    • >= 4.0.0, < 4.9.0: Affected

    No fix published

  • next-auth npm

    Affected ranges
    • SEMVER: < 3.29.8

    Update to 3.29.8

  • next-auth npm

    Affected ranges
    • SEMVER: ≥ 4.0.0, < 4.9.0

    Update to 4.9.0

Original sources

Check your server →