CVE-2022-31150
CVE-2022-31150 · CRLF injection in request headers
This page contains facts from public vulnerability sources. Check the original advisory before updating.
undici is an HTTP/1.1 client, written from scratch for Node.js. It is possible to inject CRLF sequences into request headers in undici in versions less than 5.7.1. A fix was released in version 5.8.0. Sanitizing all HTTP headers from untrusted sources to eliminate `\r\n` is a workaround for this issue.
CVSS 5.3 · Medium · EPSS 1.5% · Fix available
- Published
- Updated
Affected products and versions
undici
- Versions
- < v5.7.1, >= v5.8.0: Affected
No fix published
node-undici Debian:12
- Affected ranges
- ECOSYSTEM: < 5.8.0+dfsg1+~cs18.9.16-1
Update to 5.8.0+dfsg1+~cs18.9.16-1
node-undici Debian:13
- Affected ranges
- ECOSYSTEM: < 5.8.0+dfsg1+~cs18.9.16-1
Update to 5.8.0+dfsg1+~cs18.9.16-1
node-undici Debian:14
- Affected ranges
- ECOSYSTEM: < 5.8.0+dfsg1+~cs18.9.16-1
Update to 5.8.0+dfsg1+~cs18.9.16-1
undici npm
- Affected ranges
- SEMVER: < 5.8.0
Update to 5.8.0
node-undici Ubuntu:24.04:LTS
- Versions
- 5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1
- 5.26.3+dfsg1+~cs23.10.12-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-undici Ubuntu:25.10
- Versions
- 7.3.0+dfsg1+~cs24.12.11-1
- 7.3.0+dfsg1+~cs24.12.11-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-undici Ubuntu:26.10
- Versions
- 7.18.2+dfsg+~cs3.2.0-1build1
- 7.24.6+dfsg+~cs3.2.0-3
- 8.5.0+dfsg+~cs3.2.0-2
- 8.5.0+dfsg+~cs3.2.0-3
- 8.9.0+dfsg+~cs3.2.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-undici Ubuntu:26.04:LTS
- Versions
- 7.3.0+dfsg1+~cs24.12.11-2
- 7.16.0+dfsg+~cs3.2.0-2
- 7.18.2+dfsg+~cs3.2.0-1
- 7.18.2+dfsg+~cs3.2.0-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published