CVE-2022-31604
CVE-2022-31604
This page contains facts from public vulnerability sources. Check the original advisory before updating.
NVFLARE, versions prior to 2.1.2, contains a vulnerability in its PKI implementation module, where The CA credentials are transported via pickle and no safe deserialization. The deserialization of Untrusted Data may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity.
CVSS 9.8 · Critical · EPSS 2.1% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
nvidia flare
- Versions
- All versions prior to 2.1.2: Affected
No fix published
nvflare PyPI
- Versions
- 0.1.3
- 0.9.0
- 1.0.0
- 1.0.1
- 1.0.2
- 1.1.0
- 1.1.1
- 2.0.0
- 2.0.1
- 2.0.10
- 2.0.11
- 2.0.12
- 2.0.13
- 2.0.14
- 2.0.15
- 2.0.16
- 2.0.18
- 2.0.19
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- 2.1.0
- 2.1.1
- Affected ranges
- ECOSYSTEM: < 2.1.2
Update to 2.1.2
nvflare PyPI
- Versions
- 0.1.3
- 0.9.0
- 1.0.0
- 1.0.1
- 1.0.2
- 1.1.0
- 1.1.1
- 2.0.0
- 2.0.1
- 2.0.10
- 2.0.11
- 2.0.12
- 2.0.13
- 2.0.14
- 2.0.15
- 2.0.16
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- 2.1.0
- 2.1.1
- 2.0.18
- 2.0.19
- Affected ranges
- ECOSYSTEM: < 2.1.2
Update to 2.1.2