CVE-2022-31624
CVE-2022-31624
This page contains facts from public vulnerability sources. Check the original advisory before updating.
MariaDB Server before 10.7 is vulnerable to Denial of Service. While executing the plugin/server_audit/server_audit.c method log_statement_ex, the held lock lock_bigbuffer is not released correctly, which allows local users to trigger a denial of service due to the deadlock.
CVSS 5.5 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
mariadb-10.5 Debian:11
- Versions
- 1:10.5.11-1
- 1:10.5.12-0+deb11u1
- 1:10.5.12-1
- 1:10.5.13-0+deb11u1
- Affected ranges
- ECOSYSTEM: < 1:10.5.15-0+deb11u1
Update to 1:10.5.15-0+deb11u1
mariadb-10.0 Ubuntu:16.04:LTS
- Versions
- 10.0.20-0ubuntu0.15.04.1
- 10.0.22-0ubuntu1
- 10.0.23-1
- 10.0.23-2
- 10.0.24-7
- 10.0.25-0ubuntu0.16.04.1
- 10.0.27-0ubuntu0.16.04.1
- 10.0.28-0ubuntu0.16.04.1
- 10.0.29-0ubuntu0.16.04.1
- 10.0.31-0ubuntu0.16.04.2
- 10.0.33-0ubuntu0.16.04.1
- 10.0.34-0ubuntu0.16.04.1
- 10.0.36-0ubuntu0.16.04.1
- 10.0.38-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mariadb-10.1 Ubuntu:18.04:LTS
- Versions
- 10.1.25-1
- 1:10.1.29-6
- 1:10.1.34-0ubuntu0.18.04.1
- 1:10.1.38-0ubuntu0.18.04.1
- 1:10.1.38-0ubuntu0.18.04.2
- 1:10.1.40-0ubuntu0.18.04.1
- 1:10.1.41-0ubuntu0.18.04.1
- 1:10.1.43-0ubuntu0.18.04.1
- 1:10.1.44-0ubuntu0.18.04.1
- 1:10.1.47-0ubuntu0.18.04.1
- 1:10.1.48-0ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mariadb-10.3 Ubuntu:20.04:LTS
- Versions
- 1:10.3.17-1
- 1:10.3.18-1
- 1:10.3.19-1
- 1:10.3.21-2
- 1:10.3.22-1
- 1:10.3.22-1ubuntu1
- 1:10.3.25-0ubuntu0.20.04.1
- 1:10.3.29-0ubuntu0.20.04.1
- 1:10.3.30-0ubuntu0.20.04.1
- 1:10.3.31-0ubuntu0.20.04.1
- Affected ranges
- ECOSYSTEM: < 1:10.3.32-0ubuntu0.20.04.1
Update to 1:10.3.32-0ubuntu0.20.04.1