CVE-2022-33891
CVE-2022-33891 · Apache Spark shell command injection vulnerability via Spark UI
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This affects Apache Spark versions 3.0.3 and earlier, versions 3.1.1 to 3.1.2, and versions 3.2.0 to 3.2.1.
CVSS 8.8 · High · EPSS 93.2% · In KEV · Public exploit · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache spark
- Versions
- ≥ 3.0.3 and earlier, ≤ 3.0.3: Affected (custom)
- ≥ 3.1.1 to 3.1.2, ≤ 3.1.2: Affected (custom)
- ≥ 3.2.0 to 3.2.1, ≤ 3.2.1: Affected (custom)
No fix published
org.apache.spark:spark-parent_2.12 Maven
- Versions
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 3.0.0
- 3.0.0-preview
- 3.0.0-preview2
- 3.0.1
- 3.0.2
- 3.0.3
- Affected ranges
- ECOSYSTEM: ≤ 3.0.3
No fix published
org.apache.spark:spark-parent_2.12 Maven
- Versions
- 3.1.1
- 3.1.2
- 3.1.3
- 3.2.0
- 3.2.1
- Affected ranges
- ECOSYSTEM: ≥ 3.1.1, < 3.2.2
Update to 3.2.2
pyspark PyPI
- Versions
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.1
- 3.1.2
- Affected ranges
- ECOSYSTEM: < 3.1.3
Update to 3.1.3
pyspark PyPI
- Versions
- 3.2.0
- 3.2.1
- Affected ranges
- ECOSYSTEM: ≥ 3.2.0, < 3.2.2
Update to 3.2.2
pyspark PyPI
- Versions
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.1
- 3.1.2
- 3.2.0
- 3.2.1
- Affected ranges
- ECOSYSTEM: < 3.1.3 ∪ ≥ 3.2.0, < 3.2.2
Update to 3.1.3; Update to 3.2.2
Original sources
- https://lists.apache.org/thread/p847l3kopoo5bjtmxrcwk21xp6tjxqlc
- http://packetstormsecurity.com/files/168309/Apache-Spark-Unauthenticated-Command-Injection.html
- http://www.openwall.com/lists/oss-security/2023/05/02/1
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-33891
- https://nvd.nist.gov/vuln/detail/CVE-2022-33891