CVE-2022-34266
CVE-2022-34266
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The libtiff-4.0.3-35.amzn2.0.1 package for LibTIFF on Amazon Linux 2 allows attackers to cause a denial of service (application crash), a different vulnerability than CVE-2022-0562. When processing a malicious TIFF file, an invalid range may be passed as an argument to the memset() function within TIFFFetchStripThing() in tif_dirread.c. This will cause TIFFFetchStripThing() to segfault after use of an uninitialized resource.
CVSS 5.5 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
tiff Ubuntu:Pro:14.04:LTS
- Versions
- 4.0.2-4ubuntu3
- 4.0.3-5ubuntu1
- 4.0.3-6
- 4.0.3-6ubuntu1
- 4.0.3-7
- 4.0.3-7ubuntu0.1
- 4.0.3-7ubuntu0.2
- 4.0.3-7ubuntu0.3
- 4.0.3-7ubuntu0.4
- 4.0.3-7ubuntu0.6
- 4.0.3-7ubuntu0.7
- 4.0.3-7ubuntu0.8
- 4.0.3-7ubuntu0.9
- 4.0.3-7ubuntu0.10
- 4.0.3-7ubuntu0.11
- Affected ranges
- ECOSYSTEM: < 4.0.3-7ubuntu0.11+esm1
Update to 4.0.3-7ubuntu0.11+esm1
tiff Ubuntu:Pro:16.04:LTS
- Versions
- 4.0.3-12.3ubuntu2
- 4.0.5-1
- 4.0.6-1
- 4.0.6-1ubuntu0.1
- 4.0.6-1ubuntu0.2
- 4.0.6-1ubuntu0.3
- 4.0.6-1ubuntu0.4
- 4.0.6-1ubuntu0.5
- 4.0.6-1ubuntu0.6
- 4.0.6-1ubuntu0.7
- 4.0.6-1ubuntu0.8
- Affected ranges
- ECOSYSTEM: < 4.0.6-1ubuntu0.8+esm1
Update to 4.0.6-1ubuntu0.8+esm1
tiff Ubuntu:18.04:LTS
- Versions
- 4.0.8-5
- 4.0.8-6
- 4.0.9-1
- 4.0.9-2
- 4.0.9-3
- 4.0.9-4
- 4.0.9-4ubuntu1
- 4.0.9-5
- 4.0.9-5ubuntu0.1
- 4.0.9-5ubuntu0.2
- 4.0.9-5ubuntu0.3
- 4.0.9-5ubuntu0.4
- Affected ranges
- ECOSYSTEM: < 4.0.9-5ubuntu0.5
Update to 4.0.9-5ubuntu0.5
tiff Ubuntu:20.04:LTS
- Versions
- 4.0.10+git191003-1
- 4.1.0+git191117-1
- 4.1.0+git191117-2
- 4.1.0+git191117-2build1
- 4.1.0+git191117-2ubuntu0.20.04.1
- 4.1.0+git191117-2ubuntu0.20.04.2
- Affected ranges
- ECOSYSTEM: < 4.1.0+git191117-2ubuntu0.20.04.3
Update to 4.1.0+git191117-2ubuntu0.20.04.3