CVE-2022-34293
CVE-2022-34293
This page contains facts from public vulnerability sources. Check the original advisory before updating.
wolfSSL before 5.4.0 allows remote attackers to cause a denial of service via DTLS because a check for return-routability can be skipped.
CVSS 7.5 · High · EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wolfssl Debian:12
- Affected ranges
- ECOSYSTEM: < 5.5.3-1
Update to 5.5.3-1
wolfssl Debian:13
- Affected ranges
- ECOSYSTEM: < 5.5.3-1
Update to 5.5.3-1
wolfssl Ubuntu:16.04:LTS
- Versions
- 3.4.8+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:18.04:LTS
- Versions
- 3.10.2+dfsg-2
- 3.12.0+dfsg-1
- 3.12.2+dfsg-1
- 3.13.0+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:20.04:LTS
- Versions
- 4.1.0+dfsg-2
- 4.2.0+dfsg-1
- 4.2.0+dfsg-2
- 4.2.0+dfsg-3
- 4.3.0+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:22.04:LTS
- Versions
- 4.6.0-3
- 5.0.0-1
- 5.1.1-1
- 5.2.0-1
- 5.2.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:24.04:LTS
- Versions
- 5.5.4-2
- 5.5.4-2.1
- 5.6.4-2
- 5.6.6-1.2
- 5.6.6-1.3
- 5.6.6-1.3build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:25.10
- Versions
- 5.7.2-0.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:26.10
- Versions
- 5.9.1-0.1
- 5.9.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:26.04:LTS
- Versions
- 5.7.2-0.1
- 5.8.2-1.2
- 5.8.4-1
- 5.9.1-0.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published