CVE-2022-34305
CVE-2022-34305 · XSS in examples web application
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Apache Tomcat 10.1.0-M1 to 10.1.0-M16, 10.0.0-M1 to 10.0.22, 9.0.30 to 9.0.64 and 8.5.50 to 8.5.81 the Form authentication example in the examples web application displayed user provided data without filtering, exposing a XSS vulnerability.
CVSS 6.1 · Medium · EPSS 6.7% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache tomcat
- Versions
- Apache Tomcat 8.5 8.5.50 to 8.5.81: Affected
- Apache Tomcat 9 9.0.30 to 9.0.64: Affected
- Apache Tomcat 10.0 10.0.0-M1 to 10.0.22: Affected
- Apache Tomcat 10.1 10.1.0-M1 to 10.1.0-M16: Affected
No fix published
tomcat9 Debian:12
- Affected ranges
- ECOSYSTEM: < 9.0.65-1
Update to 9.0.65-1
tomcat9 Debian:13
- Affected ranges
- ECOSYSTEM: < 9.0.65-1
Update to 9.0.65-1
tomcat9 Debian:14
- Affected ranges
- ECOSYSTEM: < 9.0.65-1
Update to 9.0.65-1
tomcat9 Ubuntu:Pro:20.04:LTS
- Versions
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- 9.0.31-1ubuntu0.6
- 9.0.31-1ubuntu0.7
- 9.0.31-1ubuntu0.8
- 9.0.31-1ubuntu0.9
- 9.0.31-1ubuntu0.9+esm1
- 9.0.31-1ubuntu0.9+esm2
- 9.0.31-1ubuntu0.9+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat9 Ubuntu:Pro:22.04:LTS
- Versions
- 9.0.43-3
- 9.0.54-1
- 9.0.55-1
- 9.0.58-1
- 9.0.58-1ubuntu0.1
- 9.0.58-1ubuntu0.1+esm1
- 9.0.58-1ubuntu0.1+esm2
- 9.0.58-1ubuntu0.1+esm3
- 9.0.58-1ubuntu0.1+esm4
- 9.0.58-1ubuntu0.2
- 9.0.58-1ubuntu0.2+esm1
- 9.0.58-1ubuntu0.2+esm2
- 9.0.58-1ubuntu0.2+esm3
- 9.0.58-1ubuntu0.2+esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published