CVE-2022-34903
CVE-2022-34903
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GnuPG through 2.3.6, in unusual situations where an attacker possesses any secret-key information from a victim's keyring and other constraints (e.g., use of GPGME) are met, allows signature forgery via injection into the status line.
CVSS 6.5 · Medium · EPSS 2.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
gnupg2 Debian:12
- Affected ranges
- ECOSYSTEM: < 2.2.35-3
Update to 2.2.35-3
gnupg2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.2.35-3
Update to 2.2.35-3
gnupg2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.2.35-3
Update to 2.2.35-3
gnupg Ubuntu:Pro:14.04:LTS
- Versions
- 1.4.14-1ubuntu2
- 1.4.15-1.1ubuntu1
- 1.4.15-1.1ubuntu2
- 1.4.15-2ubuntu1
- 1.4.16-1ubuntu1
- 1.4.16-1ubuntu2
- 1.4.16-1ubuntu2.1
- 1.4.16-1ubuntu2.3
- 1.4.16-1ubuntu2.4
- 1.4.16-1ubuntu2.5
- 1.4.16-1ubuntu2.6
- Affected ranges
- ECOSYSTEM: < 1.4.16-1ubuntu2.6+esm1
Update to 1.4.16-1ubuntu2.6+esm1
gnupg Ubuntu:Pro:16.04:LTS
- Versions
- 1.4.18-7ubuntu1
- 1.4.19-6ubuntu1
- 1.4.20-1ubuntu1
- 1.4.20-1ubuntu2
- 1.4.20-1ubuntu3
- 1.4.20-1ubuntu3.1
- 1.4.20-1ubuntu3.2
- 1.4.20-1ubuntu3.3
- Affected ranges
- ECOSYSTEM: < 1.4.20-1ubuntu3.3+esm2
Update to 1.4.20-1ubuntu3.3+esm2
gnupg2 Ubuntu:Pro:16.04:LTS
- Versions
- 2.0.28-3ubuntu1
- 2.0.28-3ubuntu2
- 2.1.11-6ubuntu1
- 2.1.11-6ubuntu2
- 2.1.11-6ubuntu2.1
- Affected ranges
- ECOSYSTEM: < 2.1.11-6ubuntu2.1+esm1
Update to 2.1.11-6ubuntu2.1+esm1
gnupg2 Ubuntu:18.04:LTS
- Versions
- 2.1.15-1ubuntu8
- 2.2.4-1ubuntu1
- 2.2.4-1ubuntu1.1
- 2.2.4-1ubuntu1.2
- 2.2.4-1ubuntu1.3
- 2.2.4-1ubuntu1.4
- 2.2.4-1ubuntu1.5
- Affected ranges
- ECOSYSTEM: < 2.2.4-1ubuntu1.6
Update to 2.2.4-1ubuntu1.6
gnupg2 Ubuntu:20.04:LTS
- Versions
- 2.2.12-1ubuntu3
- 2.2.17-3ubuntu1
- 2.2.19-3ubuntu2
- 2.2.19-3ubuntu2.1
- Affected ranges
- ECOSYSTEM: < 2.2.19-3ubuntu2.2
Update to 2.2.19-3ubuntu2.2
gnupg2 Ubuntu:22.04:LTS
- Versions
- 2.2.20-1ubuntu4
- 2.2.27-2ubuntu1
- 2.2.27-3ubuntu1
- 2.2.27-3ubuntu2
- Affected ranges
- ECOSYSTEM: < 2.2.27-3ubuntu2.1
Update to 2.2.27-3ubuntu2.1
Original sources
- https://www.openwall.com/lists/oss-security/2022/06/30/1
- https://bugs.debian.org/1014157
- https://dev.gnupg.org/T6027
- http://www.openwall.com/lists/oss-security/2022/07/02/1
- https://www.debian.org/security/2022/dsa-5174
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NPTAR76EIZY7NQFENSOZO7U473257OVZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VN63GBTMRWO36Y7BKA2WQHROAKCXKCBL/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FRLWJQ76A4UKHI3Q36BKSJKS4LFLQO33/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VU64FUVG2PRZBSHFOQRSP7KDVEIZ23OS/
- https://security.netapp.com/advisory/ntap-20220826-0005/
- https://nvd.nist.gov/vuln/detail/CVE-2022-34903