p PatchFirst

CVE-2022-35653

CVE-2022-35653

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

CVSS 6.1 · Medium · EPSS 4.8% · Public exploit · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • moodle

    Versions
    • Fixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • v4.0.0
    • v4.0.0-beta
    • v4.0.0-rc1
    • v4.0.0-rc2
    • v4.0.0-rc3
    • v4.0.0-rc4
    • v4.0.1
    Affected ranges
    • ECOSYSTEM: ≥ 4.0, < 4.0.2

    Update to 4.0.2

  • moodle/moodle Packagist

    Versions
    • v3.11.0
    • v3.11.0-beta
    • v3.11.0-rc1
    • v3.11.0-rc2
    • v3.11.1
    • v3.11.2
    • v3.11.3
    • v3.11.4
    • v3.11.5
    • v3.11.6
    • v3.11.7
    Affected ranges
    • ECOSYSTEM: ≥ 3.11, < 3.11.8

    Update to 3.11.8

  • moodle/moodle Packagist

    Versions
    • v3.9.0
    • v3.9.0-beta
    • v3.9.0-rc1
    • v3.9.0-rc2
    • v3.9.0-rc3
    • v3.9.1
    • v3.9.10
    • v3.9.11
    • v3.9.12
    • v3.9.13
    • v3.9.14
    • v3.9.2
    • v3.9.3
    • v3.9.4
    • v3.9.5
    • v3.9.6
    • v3.9.7
    • v3.9.8
    • v3.9.9
    Affected ranges
    • ECOSYSTEM: ≥ 3.9, < 3.9.15

    Update to 3.9.15

  • moodle Ubuntu:Pro:16.04:LTS

    Versions
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • moodle Ubuntu:Pro:18.04:LTS

    Versions
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →