p PatchFirst

CVE-2022-35924

CVE-2022-35924 · Verification requests (magic link) sent to unwanted emails

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NextAuth.js is a complete open source authentication solution for Next.js applications. `next-auth` users who are using the `EmailProvider` either in versions before `4.10.3` or `3.29.10` are affected. If an attacker could forge a request that sent a comma-separated list of emails (eg.: `[email protected],[email protected]`) to the sign-in endpoint, NextAuth.js would send emails to both the attacker and the victim's e-mail addresses. The attacker could then login as a newly created user with the email being `[email protected],[email protected]`. This means that basic authorization like `email.endsWith("@victim.com")` in the `signIn` callback would fail to communicate a threat to the developer and would let the attacker bypass authorization, even with an `@attacker.com` address. This vulnerability has been patched in `v4.10.3` and `v3.29.10` by normalizing the email value that is sent to the sign-in endpoint before accessing it anywhere else. We also added a `normalizeIdentifier` callback on the `EmailProvider` configuration, where you can further tweak your requirements for what your system considers a valid e-mail address. (E.g.: strict RFC2821 compliance). Users are advised to upgrade. There are no known workarounds for this vulnerability. If for some reason you cannot upgrade, you can normalize the incoming request using Advanced Initialization.

CVSS 9.1 · Critical · EPSS 1.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next-auth

    Versions
    • >= 4.0.0, < 4.10.3: Affected
    • < 3.29.10: Affected

    No fix published

  • next-auth npm

    Affected ranges
    • SEMVER: ≥ 4.0.0, < 4.10.3

    Update to 4.10.3

  • next-auth npm

    Affected ranges
    • SEMVER: < 3.29.10

    Update to 3.29.10

Original sources

Check your server →