p PatchFirst

CVE-2022-36037

CVE-2022-36037 · Cross-site scripting (XSS) from dynamic options in the multiselect field in Kirby

This page contains facts from public vulnerability sources. Check the original advisory before updating.

kirby is a content management system (CMS) that adapts to many different projects and helps you build your own ideal interface. Cross-site scripting (XSS) is a type of vulnerability that allows execution of any kind of JavaScript code inside the Panel session of the same or other users. In the Panel, a harmful script can for example trigger requests to Kirby's API with the permissions of the victim. If bad actors gain access to your group of authenticated Panel users they can escalate their privileges via the Panel session of an admin user. Depending on your site, other JavaScript-powered attacks are possible. The multiselect field allows selection of tags from an autocompleted list. Unfortunately, the Panel in Kirby 3.5 used HTML rendering for the raw option value. This allowed **attackers with influence on the options source** to store HTML code. The browser of the victim who visited a page with manipulated multiselect options in the Panel will then have rendered this malicious HTML code when the victim opened the autocomplete dropdown. Users are *not* affected by this vulnerability if you don't use the multiselect field or don't use it with options that can be manipulated by attackers. The problem has been patched in Kirby 3.5.8.1.

CVSS 5.9 · Medium · EPSS 0.9% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • kirby

    Versions
    • < 3.5.8.1: Affected

    No fix published

  • getkirby/cms Packagist

    Versions
    • 3.0.0
    • 3.0.1
    • 3.0.1-rc.1
    • 3.0.2
    • 3.0.2-rc.1
    • 3.0.3
    • 3.0.3-rc.1
    • 3.0.3-rc.2
    • 3.0.3-rc.3
    • 3.1.0
    • 3.1.0-rc.1
    • 3.1.1
    • 3.1.2
    • 3.1.2-rc.1
    • 3.1.3
    • 3.1.3-rc.1
    • 3.1.4
    • 3.1.4-rc.1
    • 3.2.0
    • 3.2.0-rc.1
    • 3.2.0-rc.2
    • 3.2.0-rc.3
    • 3.2.0-rc.4
    • 3.2.1
    • 3.2.1-rc.1
    • 3.2.2
    • 3.2.3
    • 3.2.3-rc.1
    • 3.2.4
    • 3.2.4-rc.1
    • 3.2.5
    • 3.2.5-rc.1
    • 3.2.5-rc.2
    • 3.3.0
    • 3.3.0-rc.1
    • 3.3.0-rc.2
    • 3.3.0-rc.3
    • 3.3.0-rc.4
    • 3.3.0-rc.5
    • 3.3.1
    • 3.3.1-rc.1
    • 3.3.2
    • 3.3.2-rc.1
    • 3.3.3
    • 3.3.3-rc.1
    • 3.3.4
    • 3.3.4-rc.1
    • 3.3.5
    • 3.3.5-rc.1
    • 3.3.6
    • 3.4.0
    • 3.4.0-rc.1
    • 3.4.0-rc.2
    • 3.4.0-rc.3
    • 3.4.1
    • 3.4.1-rc.1
    • 3.4.2
    • 3.4.3
    • 3.4.3-rc.1
    • 3.4.4
    • 3.4.4-rc.1
    • 3.4.5
    • 3.5.0
    • 3.5.0-rc.1
    • 3.5.0-rc.2
    • 3.5.0-rc.3
    • 3.5.0-rc.4
    • 3.5.0-rc.5
    • 3.5.0-rc.6
    • 3.5.0-rc.7
    • 3.5.1
    • 3.5.1-rc.1
    • 3.5.2
    • 3.5.2-rc.1
    • 3.5.3
    • 3.5.3.1
    • 3.5.4
    • 3.5.5
    • 3.5.5-rc.1
    • 3.5.6
    • 3.5.6-rc.1
    • 3.5.7
    • 3.5.7-rc.1
    • 3.5.7.1
    • 3.5.8
    Affected ranges
    • ECOSYSTEM: < 3.5.8.1

    Update to 3.5.8.1

Original sources

Check your server →