CVE-2022-36108
CVE-2022-36108 · Cross-Site Scripting in typo3/cms-core
This page contains facts from public vulnerability sources. Check the original advisory before updating.
TYPO3 is an open source PHP based web content management system released under the GNU GPL. It has been discovered that the `f:asset.css` view helper is vulnerable to cross-site scripting when user input is passed as variables to the CSS. Update to TYPO3 version 10.4.32 or 11.5.16 that fix the problem. There are no known workarounds for this issue.
CVSS 6.5 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
typo3
- Versions
- >= 10.3.0, < 10.4.32: Affected
- >= 11.0.0, < 11.5.16: Affected
No fix published
typo3/cms-core Packagist
- Versions
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.10
- v10.4.11
- v10.4.12
- v10.4.13
- v10.4.14
- v10.4.15
- v10.4.16
- v10.4.17
- v10.4.18
- v10.4.19
- v10.4.2
- v10.4.20
- v10.4.21
- v10.4.22
- v10.4.23
- v10.4.24
- v10.4.25
- v10.4.26
- v10.4.27
- v10.4.28
- v10.4.29
- v10.4.3
- v10.4.30
- v10.4.31
- v10.4.4
- v10.4.5
- v10.4.6
- v10.4.7
- v10.4.8
- v10.4.9
- Affected ranges
- ECOSYSTEM: ≥ 10.3.0, < 10.4.32
Update to 10.4.32
typo3/cms-core Packagist
- Versions
- v11.0.0
- v11.1.0
- v11.1.1
- v11.2.0
- v11.3.0
- v11.3.1
- v11.3.2
- v11.3.3
- v11.4.0
- v11.5.0
- v11.5.1
- v11.5.10
- v11.5.11
- v11.5.12
- v11.5.13
- v11.5.14
- v11.5.15
- v11.5.2
- v11.5.3
- v11.5.4
- v11.5.5
- v11.5.6
- v11.5.7
- v11.5.8
- v11.5.9
- Affected ranges
- ECOSYSTEM: ≥ 11.0.0, < 11.5.16
Update to 11.5.16
typo3/cms Packagist
- Versions
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.10
- v10.4.11
- v10.4.12
- v10.4.13
- v10.4.14
- v10.4.15
- v10.4.16
- v10.4.17
- v10.4.18
- v10.4.19
- v10.4.2
- v10.4.20
- v10.4.21
- v10.4.22
- v10.4.23
- v10.4.24
- v10.4.25
- v10.4.26
- v10.4.27
- v10.4.28
- v10.4.29
- v10.4.3
- v10.4.30
- v10.4.31
- v10.4.4
- v10.4.5
- v10.4.6
- v10.4.7
- v10.4.8
- v10.4.9
- Affected ranges
- ECOSYSTEM: ≥ 10.3.0, < 10.4.32
Update to 10.4.32
typo3/cms Packagist
- Versions
- v11.0.0
- v11.1.0
- v11.1.1
- v11.2.0
- v11.3.0
- v11.3.1
- v11.3.2
- v11.3.3
- v11.4.0
- v11.5.0
- v11.5.1
- v11.5.10
- v11.5.11
- v11.5.12
- v11.5.13
- v11.5.14
- v11.5.15
- v11.5.2
- v11.5.3
- v11.5.4
- v11.5.5
- v11.5.6
- v11.5.7
- v11.5.8
- v11.5.9
- Affected ranges
- ECOSYSTEM: ≥ 11.0.0, < 11.5.16
Update to 11.5.16