p PatchFirst

CVE-2022-36124

CVE-2022-36124 · Memory overconsumption in Avro Rust SDK

This page contains facts from public vulnerability sources. Check the original advisory before updating.

It is possible for a Reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.

CVSS 7.5 · High · EPSS 1.6% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • apache avro

    Versions
    • ≥ unspecified, < 0.14.0: Affected (custom)

    Update to 0.14.0

  • avro PyPI

    No fix published

Original sources

Check your server →